Github Boards Devices Community Docs Blog

0.9.4 in vscode platformio build fails

Could someone help me with why the build fails? It fails on fetching 1technophile/Arduino-Log#d13cd80 it seems.

On mac with latest vscode and Python 3.8.4 and 0.9.4 of OMG.
See error: https://paste.ubuntu.com/p/nhPpzGZs3K/

Edit: tried with cmd line pio and pio in virtualenv as well as using python 3.7 but same results

Try maybe to remove the #d13cd80 reference by using:
1technophile/Arduino-Log in platformio.ini file

I tried this and it yielded the same result.

Did you tried to clean your environment with the little garbage in the bottom blue bar?

Try with this:

arduinolog = https://github.com/1technophile/Arduino-Log.git#d13cd80

EDIT:
the new arduino log worked. Now it fails on Library Manager: Installing 1technophile/rc-switch#8fc6d06
KeyError: ‘versions’:

EDIT2: I think it is the same. If I add the http url it works

This is due to evolutions in platformio, you have several solutions:

  • Replace each library call by the new format
    arduinolog = https://github.com/1technophile/Arduino-Log.git#d13cd80
    instead of
    arduinolog =1technophile/Arduino-Log#d13cd80

  • Use the development branch which is close to a beta stage

Thanks! I’ll try with the dev branch

1 Like