Sending RF 433 to SFRB on Openhab

Hello Guys, I have the SFRB integrated on Openhab, and it is receiving correctly the RF 433 signals from contact sensors (windows and doors), PIR sensors, wall switch and doorbell.

I want to go a step further, sending RF 433 signals to some devices, using the Openhab. The MQTT broker is running in Openhab (as I’m using it to get the codes from SFRB), but I don’t know how to implement the command to Openhab publish via MQTT a RF 433 signal value.

Doing some researches I’ve found that the topic for Publish should be “home/OpenMQTTGateway/commands/MQTTtoSRFB”, but I’m struggling to get this info inside the Rules on Openhab. All the MQTT configurations I’ve done using the PaperUI, not editing the text files (Use .items and .sitemap files to create the items, but not for linking the Channels, did that on PaperUI).


Could you indicate which version of Openhab you are running ? And if it is 2.4 if you are running the mqtt legacy binding ?

Hello! It’s the 2.4 Version (stable) installed on a Raspberry. The MQTT binding was installed via paperui addons section, but not sure if its “legacy” (I can succesfully manually add New generic mqtt “things” and link them with existing items, receiving the RF 433 codes)

with the 2.4 mqtt binding not the legacy one you can follow this guide:

Sorry to bother again, I’ve read the docs, but still having problems. The system is receiving the codes as expected, and can get some sensors wokring in openhab.

The problem is to send signals.

For example, I have a RF Wall Switch, and within MQTT.fx software, when subscribed to the topic “home/OpenMQTTGateway/SRFBtoMQTT”, displays the follow code when the button is pressed:

I use this physical RF switch to turn ON/OFF a Sonoff RF Bulb. Pressing the switch, the light turns on and off as expected, and I can see the Bridge capturing the codes when the button is pressed.

The problem is how to SEND a RF command from OpenHab to the Sonoff Bridge, and the bridge convert it from MQTT to the real 433 Signal.

I’ve tried different configurations on MQTT.fx, using the code from Wall Switch as example, trying to make the Bridge broadcast the RF “value”:12381864, or the “raw”:21DE0104038EBCEEA8, and even the whole line, but none of them resulted in a working condition, as the RF bulb does not seems to get the signals from the bridge.

I’ve tried published the messages to the topic “home/OpenMQTTGateway/commands/MQTTtoSRFB/” and also to “home/OpenMQTTGateway/commands/MQTTtoSRFB/Raw”



Unfortunately I have seen that sometimes the rf bridge is not able to control wall plugs. Indeed i don’t see a difference between the on and off “value” .
To verify that the issue comes from the rf bridge , you can try to do an OMG with an esp8266 and some basic receiver/emitter. See if you are able to receive a different value depending on ON OFF button and try to reproduce.
If so you could apply a the direct hardware mod to the rfbridge.