Switching Active Receiver Module not working?

Hi all, what a great initiative this is !
It seems it’s going to replace my old RFXCOM device if I can get it working.

Device : LilyGO TTGO ESP32 LORA module (hint & tips from Andreas)

Sofar, I’m able to install the : lilygo-rtl_433 binary through the web interface.
I can change the WiFi and MQTT settings and see the MQTT messages being generated.

However trying to see my KAKU devices.
I noticed the active receiver : actRec = 3
Meaning RTL_433 from the overview below.

1 - PiLight
2 - RF
3 - RTL_433
4 - RF2

Trying to switch to RF2 (for the KAKU devices) does not work.
Sending commands : MQTTtoRF2 with JSON payload :
“active”: true

Does the binary version using the web installer not contain the other receiver modules ?


The receiver module in a Heltec and LilyGo board is only configured for use with rtl_433_ESP module and not the other receiver options.

Receiver switching is available with the other RF receivers, including CC1101

Thanks NorthernMan54.

Would it be possible to generate my own binary with the RF2 receiver on the LilyGo board
or is there a limitation on the LilyGo board itself ?

By the way my LilyGo LoRa model is : T3 V1.6.1 433Mhz

Reading your comments once more.
The radio module on the LilyGo seems to be the culprit and allows only rtl_443_ESP, rt ?

Correct the boards based on the SX127x chipset on support rtl_433_esp.

The receiver code for the SX127x is more complex hence, the lack of suppprt for the other modules.