Github Devices Community Docs Blog

Unable to Send IR Signal

Hello,

I’m using OMG with only ZGatewayIR. I have tried both master & development branch.
I’m using default pinout on ESP8266.

RX is OK.
TX doesn’t work.

I have tried IRSendDemo for my Sony TV to Power ON & OFF, it works with D0/PIN16.
With OMG I have replace with a normal LED. I see the blinking while sending…

FYI, the message format on repeatIRwMQTT is wrong :

home/OpenMQTTGateway/commands/MQTTtoIR 1587664935

must be :

home/OpenMQTTGateway/commands/MQTTtoIR '{"value":1587664935}'

I have tried to send Raw signal, but it still doesn’t work. MQTT message is at 1024.

I don’t understand why it fails.

Here is an example of my serial output :

Using NEC protocol
MQTTtoIR OK
Pub json into:
home/OpenMQTTGateway/IRtoMQTT
{"value":4294967295}
Hey I got a callback 
Store signal
Min ind: 
4
store code :
4294967295/436760
Col: val/timestamp
0:4294967295/7944
1:4294967295/13765
2:4294967295/23907
3:4294967295/25030
4:4294967295/436760
5:0/0
6:0/0
7:0/0
8:0/0
9:0/0
10:0/0
11:0/0
Data JSON stored

thanks for the help.

PS : OMG in développement branch reboots while using protocol IR_Sony.

Sorry to hijack this thread but I have a similar problem as well with my wemos D1 mini and Lolin IR shield. I do not seam to receive any IR signals looking at mqtt explorer.
I can see in mqtt explorer, the gateway topics of LWT and Version only for OpenMqttGateway.

what am I missing or doing wrong?

Hello,

You should add the protocol to the payload, it should be IR_SONY

I was receiving 2 messages on RX. First one was incomplete, so value was wrong. it works great with the 2nd message. I ran a IR receptor on Arduino to compare signal between remote and esp8266 to understand.

1 Like

Could you post for the others an example of working messages please?