Github Devices Community Docs Blog

V0.9.3 via visual studio/platformio fail

Hi, I download V0.9.3 and only modified the platformio.ini File by remmoving the “;” in front of default_envs = nodemcuv2-rf to select eactly this config.

even cleaned the Env. during build I get this:
"
Compiling .pio\build\nodemcuv2-rf\lib89e\Ethernet_ID872\EthernetClient.cpp.o
Compiling .pio\build\nodemcuv2-rf\lib89e\Ethernet_ID872\EthernetServer.cpp.o
C:\Users\Heiner.Pahlings.platformio\lib\Ethernet_ID872\src\Ethernet.cpp: In static member function ‘static void EthernetClass::begin(uint8_t*, IPAddress, IPAddress, IPAddress, IPAddress)’:
C:\Users\Heiner.Pahlings.platformio\lib\Ethernet_ID872\src\Ethernet.cpp:87:24: error: ‘class IPAddress’ has no member named ‘_address’
W5100.setIPAddress(ip._address.bytes);
^
C:\Users\Heiner.Pahlings.platformio\lib\Ethernet_ID872\src\Ethernet.cpp:88:29: error: ‘class IPAddress’ has no member named ‘_address’
W5100.setGatewayIp(gateway._address.bytes);
^
C:\Users\Heiner.Pahlings.platformio\lib\Ethernet_ID872\src\Ethernet.cpp:89:29: error: ‘class IPAddress’ has no member named ‘_address’
W5100.setSubnetMask(subnet._address.bytes);
^
*** [.pio\build\nodemcuv2-rf\lib89e\Ethernet_ID872\Ethernet.cpp.o] Error 1
=================================================== [FAILED] Took 23.63 seconds ===================================================
"

What am I doing wrong?

I tried as well another config with BLE instead of RF but same result.

I did not find a fitting Category, hence left this field open.

I hope someone could help me here.