Add Maverick ET-73 Smoker Thermometer

Apparently this rtl_433 project has support for the Maverick ET-73 Smoker Thermometer. What would it take to get this incorporated into the RF side of openMQTTGateway? There are also notes here regarding data from the unit in github under /mokus0/et73/blob/master/ (apologies, I am only allowed 2 links at the moment)


It should be included already as it is in the supported device list:

Did you try it with an SX127X based board or a CC1101 like one combination below:

  • ESP32 based device with a CC1101 transceiver
  • Heltec WiFi LoRa 32 (V2.1) and LilyGo Lora 32 V2.1
  • ESP32 DOIT DevKit V1 and Ai-Thinker R01 (SX1278)
1 Like

Thank you for that reply!

I am using a LILYGO TTGO LoRa32 V2.1_1.6 433Mhz so perhaps I have to do something to get it to be read. Only the transmitter at the smoker seems to work properly. Or should I say the receiver doesn’t seem to receive data. I thought the receiver is bad but perhaps it is on the transmitting side. I guess I need to look into the transmitting unit further.

Did you try with the receiver close to the transmitter?

They were within 10’ of each other. But after this, I now have them almost touching and do see data. Thank you for that! Hoping I can get more range, but maybe not.


Are you using the OMG release version 1.4.0 or the development version?

If you are on the last release 1.4.0 release you might want to try the development version as the included rtl_433_ESP library has been updated with tuning of the receiving parameters.

So might be worth trying and giving some feedback if the range improves for you.

I had to install PlatformIO to get the download to happen. That was 2 days ago. It reports the version back as:
version = version_tag

I will try to install again. I was trying the lilygo-rtl_433 from the uploader (option 1) then tried option 2 and was getting an error.

Can I use the OTA update to the development version?

Still depends if you downloaded the source from the 1.4.0. release or directly the development version. So hard to say, but if you downlaod the latest development branch source and build and upload in PlatformIO you will definitely be on the latest state with the library update.

Did you have issues with option 1 - web upload?

If so, do you mind sharing what they were? As the above development web upload would be the easiest to assure the rtl_433_ESP library update being included.

OTA through MQTT commands again depends which version you actually installed with PlatformIO, OTA through PlatformIO yes, with the correct environment additions.

P.S. Can you have a look in platformio.ini, what it says for

rtl_433_ESP = ?

[quote=“DigiH, post:8, topic:2281, full:true”]

Still depends if you downloaded the source from the 1.4.0. release or directly the development version. So hard to say, but if you downlaod the latest development branch source and build and upload in PlatformIO you will definitely be on the latest state with the library update.

Did you have issues with option 1 - web upload?

If so, do you mind sharing what they were? As the above development web upload would be the easiest to assure the rtl_433_ESP library update being included.[/quote]
Trying Option 1, with lilygo-rtl_433 selected, I was provided with “USB Single Serial (COM12) - Paired” as the selection for the board. I received a message stating " Failed to initialize. Try resetting your device or holding the BOOT button while selecting your serial port." and I tried various methods on holding/pushing the only button on the board. I also tried having the slider in the On and Off positions. This was done on both Chrome and Edge browsers on 2 Windows systems.
I then went to Option 2 and would get “ABS_DONE_0 false” as well as a couple other messages while it was trying to erase. I also had overwrite errors when trying to not erase the board, which I am sure we both expected. Sorry, i did not note all the issues on Option 2. Since Option 1 still does not work I wll go straight to Option 3 to try the dev version. I do not know when I can get to that, though.
The board is still giving me the above when trying Option 1.

rtl_433_ESP = GitHub - NorthernMan54/rtl_433_ESP: Trial port of the rtl_433 Library for use with OpenMQTTGateway on a ESP32 and a CC1101 Transceiver

Sorry, just got the link there :wink: could you either put it into preformatted tags or just quote if it says 0.1.6 or 0.1.7 in your platformio.ini.

If it is 0.1.7 you are on the latest development version with the rtl_433_ESP library update.

rtl_433_ESP =

Sorry about that.

And just a note: Pulling GitHub and dealing with all that is something I am clueless with. I had to install GIT and Visual Studio Code and just blindly followed the instructions I under Option 3 on installing it this way. I am thinking I installed v1.4.0. I did uncomment
default_envs = lilygo-rtl_433
and 2 lines for the HAss Discovery stuff (even though I don’t use HAss). I believe that there were 1 or 2 other lines I uncommented. Decided to just paste it all here:

;   Build options: build flags, source filter
;   Upload options: custom upload port, speed and extra flags
;   Library options: dependencies, extra library storages
;   Advanced options: extra scripting
; Please visit documentation for the other options and examples

src_dir = main
include_dir = main

extra_configs =

;                                 ENVIRONMENT CHOICE                                   ;
;Uncomment the env line corresponding to your board and modules required,              ;
;you can also adapt the modules by removing the corresponding lines in the env detail  ;
; if you go to the build flag section of your env you will see that some User_config.h ;
; parameters can be overwritten here, for example the gateway name.                    ;
; If you want to avoid the lost of your environments at each update you can put them   ;
; into a separate file called prod_env.ini, it will be automatically read by pio       ;
; an example (prod_env.ini.example) is available into the same folder as this file.    ;

;default_envs = rfbridge
;default_envs = rfbridge-direct
;default_envs = esp32dev-all-test
;default_envs = esp32dev-rf
;default_envs = esp32dev-pilight
;default_envs = esp32dev-pilight-cc1101
;default_envs = esp32dev-somfy-cc1101
;default_envs = esp32dev-pilight-somfy-cc1101
;default_envs = esp32dev-weatherstation
;default_envs = esp32dev-gf-sun-inverter
;default_envs = esp32dev-ir
;default_envs = esp32dev-ble
;default_envs = esp32dev-ble-openhab
;default_envs = esp32dev-ble-mqtt-undecoded
;default_envs = esp32dev-ble-aws
;default_envs = esp32feather-ble
;default_envs = esp32-lolin32lite-ble
;default_envs = esp32-olimex-gtw-ble-eth
;default_envs = esp32-olimex-gtw-ble-poe
;default_envs = esp32-olimex-gtw-ble-poe-iso
;default_envs = esp32-wt32-eth01-ble-eth
;default_envs = esp32-olimex-gtw-ble-wifi
;default_envs = esp32-m5stick-ble
;default_envs = esp32-m5stack-ble
;default_envs = esp32-m5tough-ble
;default_envs = esp32-m5stick-c-ble
;default_envs = esp32-m5stick-cp-ble
;default_envs = esp32-m5atom-matrix
;default_envs = esp32-m5atom-lite
;default_envs = esp32doitv1-aithinker-r01-sx1278
;default_envs = esp32dev-rtl_433
;default_envs = heltec-rtl_433
;default_envs = heltec-ble
default_envs = lilygo-rtl_433
;default_envs = lilygo-ble
;default_envs = esp32dev-multi_receiver
;default_envs = tinypico-ble
;default_envs = ttgo-lora32-v1-868
;default_envs = ttgo-lora32-v1-915
;default_envs = ttgo-t-beam
;default_envs = heltec-wifi-lora-32-868
;default_envs = heltec-wifi-lora-32-915
;default_envs = shelly-plus1
;default_envs = nodemcuv2-all-test
;default_envs = nodemcuv2-fastled-test
;default_envs = nodemcuv2-2g
;default_envs = nodemcuv2-ir
;default_envs = nodemcuv2-rs232
;default_envs = avatto-bakeey-ir
;default_envs = nodemcuv2-rf
;default_envs = nodemcuv2-rf-cc1101
;default_envs = nodemcuv2-somfy-cc1101
;default_envs = manual-wifi-test
;default_envs = openhab-test
;default_envs = nodemcuv2-mqtt-fw-test
;default_envs = rf-wifi-gateway
;default_envs = nodemcuv2-rf2
;default_envs = nodemcuv2-rf2-cc1101
;default_envs = nodemcuv2-pilight
;default_envs = nodemcuv2-weatherstation
;default_envs = sonoff-basic
;default_envs = sonoff-basic-rfr3
;default_envs = atmega-all-test
;default_envs = uno-rf
;default_envs = uno-fastled
;default_envs = esp32dev-ble-datatest
;default_envs = esp32s3-dev-c1-ble
;default_envs = esp32c3-dev-m1-ble
;default_envs = airm2m_core_esp32c3
;default_envs = thingpulse-espgateway
;default_envs = thingpulse-espgateway-ethernet

;                              ENVIRONMENTS PARAMETERS                                 ;
;Libraries and parameters shared accross environements                                 ;

arduinojson = ArduinoJson@6.18.3
arduinolog =
pubsubclient = PubSubClient@2.8
rc-switch =
newremoteswitch =
ble =
irremoteesp = IRremoteESP8266@2.8.2
irremote =
lora =
esppilight = ESPiLight@0.17.0
rfWeatherStation = WeatherStationDataRx@0.3.1
rfm69 =
rfm69spi =
rfm69_low-power = Low-Power@1.6
dht = DHT sensor library@1.3.2
unifiedsensor = Adafruit Unified Sensor@1.1.4
tsl2561 = Adafruit TSL2561@1.0.3
bme280 = SparkFun BME280@2.0.4
bmp180 = BMP180#efac46bd8d
htu21 = SparkFun HTU21D Humidity and Temperature Sensor Breakout@1.1.3
ahtx0 = Adafruit AHTX0
ina226 =
a6lib =
wifimanager32 =
wifimanager8266 =
ethernet = Ethernet
esp8266_mdns = esp8266_mdns
wire = Wire
fastled = fastled/FastLED@3.5.0
onewire = paulstoffregen/OneWire@2.3.7
dallastemperature = DallasTemperature
m5stickc = M5StickC@0.2.0
m5stickcp =
m5stack = M5Stack@0.3.1
m5tough =
smartrc-cc1101-driver-lib = SmartRC-CC1101-Driver-Lib@2.5.7
stl =
shtc3 =
rtl_433_ESP =
emodbus =  miq19/eModbus@1.0.0
gfSunInverter =
decoder =
ssd1306 = thingpulse/ESP8266 and ESP32 OLED driver for SSD1306 displays@^4.3.0
lm75 = jeremycole/I2C Temperature Sensors derived from the LM75@^1.0.3
rn8209 =

framework = arduino
lib_deps =
build_flags =
  -w ; supress all warnings
;  -E ; generate precompiled source file (.pio/build/*/src/main.ino.cpp.o), use for precompilator debuging only (prevent compilation to succeed)
;  '-DLOG_LEVEL=LOG_LEVEL_TRACE'  ; Enable trace level logging
monitor_speed = 115200

esp8266_platform = espressif8266@3.2.0
esp32_platform = espressif32@3.5.0
esp32_c3_s3_platform = espressif32@5.2.0
esp32_solo_platform =
atmelavr_platform = atmelavr@3.3.0

lib_deps =
build_flags =

lib_deps =
build_flags =

lib_deps =
build_flags =

Yes, you ale using the updated rtl_433_ESP library v0.1.7, as you likely downloaded the development source two days ago.

Unfortunately, the only other thing I could suggest is connecting a higher gain antenna to the LilyGo board, to see if the range will improve for your ET-73.

Thank you. I believe the range is good on the board. I am getting 3 weather stations from neighbors as well as a plethora of motion sensors and other devices! I think the issue is the Maverick Unit itself as the transmitting and receiving units seem to have a hard time connecting at distances where they once did as well. Maybe it is just time for a new BBQ Thermometer…

Yes, then it really sounds more like a low transmitting issue with the ET-73.

Definitely also considers some BLE BBQ thermometers for this, as there are quite a few with OpenMQTTGateway BLE compatibility from Govee, Inkbird and Ternergy

I will be looking at a few options. After learning more about the OpenMQTTGateway paradigm, I just plugged the BLE Gateway back in this morning. I had put that together a while ago to look at controlling a Fluval aquarium light, or at least send it a time refresh. I had given up on that a month ago, but will re-visit soon. (read: look for a post on this in the near future)

Thank you both, @1technophile and @DigiH for all the help on this one!!!