Add Tenergy Solis 6 channel meat thermometer to openmqttgateway

Is there any possibility that the Tenergy Solis 6 channel thermometer with bluetooth could be added to this compatibility list? I imagine its not much different from the INKBIRD thermometers as i have already got openmqttgateway installed on a esp32 board and it sees the thermometer as a iBBQ

0CB2B71B5B18 = {“id”:“0C:B2:B7:1B:5B:18”,“mac_type”:0,“name”:“iBBQ”,“manufacturerdata”:“000000000cb2b71b5b18c800c800f6fff6fff6fff6ff”,“rssi”:-43,“txpower”:0}

that is what it shows on the line in my mqtt where it sees my meat thermometer. but there are no items that could be construed as probes.

i included this image because I seen there were requests for this information in other posts having to do with the other meat thermometers. let me know if there is any other information i can provide.

Added info:
i used the following files to upload to my esp32 devkit v1

1 Like

Here is an attempt to add it into theengs decoder:

So as to test it you can replace this into platformio.ini

decoder =


decoder =

Here is the guide for platformio:

i have followed the instructions as best i could but i am new to all this esp boards and loading bin files to them. i can’t seem to understand i go from having an edited ini file in visual studio on my computer to in one of the binaries i load into my esp board. i am sure there is something that is just “assumed that i already know” here but i can’t figure it out.

any assistance for a newbie just getting into this microprocessor arena would be much appreciated.

I will give you another possibility to test in a few days.
Meanwhile could you add the 6 probes and share some data extract like this with different temperatures.


i spoke too quickly. I managed to get the visual code and platformio all setup and once i got git installed, it was damn slick! compiled and uploaded and instantly i started getting temperatures from 6 probes on the Tenergy device etc. what i am noticing though is that there is something wrong. the last 3 probes seem to be registering the same temperature as the each other. meaning 1,2,and 3 are right, so is 4, but 5 and 6 show whatever 4 shows, and change as 4 changes. the temperature being sent to mqtt does not match the temp on the device itself for 5 and 6. but 4 out of 6 aint bad for my first time at this :slight_smile: Let me know what i can provide to see why these temps are acting like this.

0CB2B71B5B18 = {“id”:“0C:B2:B7:1B:5B:18”,“mac_type”:0,“name”:“iBBQ”,“rssi”:-53,“txpower”:0,“brand”:“Tenergy”,“model”:“SOLIS 6 probes”,“model_id”:“SOLIS_6”,“tempc”:18,“tempf”:64.4,“tempc2”:19,“tempf2”:66.2,“tempc3”:16,“tempf3”:60.8,“tempc4”:19,“tempf4”:66.2,“tempc5”:19,“tempf5”:66.2,“tempc6”:19,“tempf6”:66.2}

1 Like

Good that you’ve done it!
I have found the issue and pushed an update. You can remove the .pio directory from the OpenMQTTGateway directory and upload again

I did as you suggested and now the temps are all looking correct. One more question on this, I am using this to integrate with my home assistant and along with this bbq thermometer, there are a ton of other Generic Beacon devices being picked up. What is the easiest way to filter all that down to just the thermometer device and none of the other ble devices this integration is picking up?

Thank you so much for the help and speedy responses

Cool. So as to filter you can use a white list

Is there a model identifier for this device?
Most of the time they are on the back of the device.

there is a lot # and a fcc id, and a message that says not to put it on a hot surface.

I have tried many times to get this whitelist to work but the messages keep coming. I have tried many different ways that i seen in other posts and none seem to stop all the messages from coming.

C:\Program Files\mosquitto>mosquitto_pub.exe -h -t Gateway/OpenMQTTGateway/BTtoMQTT/config -m ‘{“white-list”:[“0C:B2:B7:1B:5B:18”]}’

C:\Program Files\mosquitto>mosquitto_pub.exe -h -t Gateway/OpenMQTTGateway/BTtoMQTT/config -m ‘{“white-list”:[“0C:B2:B7:1B:5B:18”]}’

C:\Program Files\mosquitto>mosquitto_pub.exe -h -t Gateway/OpenMQTTGateway/BTtoMQTT/config -m {“white-list”:[“0C:B2:B7:1B:5B:18”]}

C:\Program Files\mosquitto>mosquitto_pub.exe -h -t Gateway/OpenMQTTGateway/BTtoMQTT/config -m {“white-list”:[“0C:B2:B7:1B:5B:18”]}

C:\Program Files\mosquitto>mosquitto_pub.exe -h -t Gateway/OpenMQTTGateway/commands/BTtoMQTT/config -m {“white-list”:[“0C:B2:B7:1B:5B:18”]}

C:\Program Files\mosquitto>mosquitto_pub.exe -h -t Gateway/OpenMQTTGateway/commands/MQTTtoBT/config -m {“white-list”:[“0C:B2:B7:1B:5B:18”]}

C:\Program Files\mosquitto>mosquitto_pub.exe -h -t Gateway/OpenMQTTGateway/commands/MQTTtoBT/config -m {“white-list”:“0C:B2:B7:1B:5B:18”}

the whitelist thing shows in mqtt explorer but does not seem to have an effect.



config = {white-list:[0C:B2:B7:1B:5B:18]}

Can you post a screenshot of mqtt explorer with the topic and payload that you are publishing. It is difficult to say from your message as the quotes may be altered by the copy/paste.

Hi cobbtm2003,

did you try sending it through MQTT Explorer, as you have on the screenshot - did you change the base topic to Gateway/ from its default home/? - but with the format ticked to JSON?

Thanks. It should be also MQTTtoBT and not the opposite

So i cleared everything and started over doing what Digih suggested and that did seem to stop all the other devices, but now my sensors for home assistant are not chowing up anymore.

I think it was more the correct order of @1technophile that did the trick :wink:

Me not knowing much about HA, what HA sensors are you talking about? Would you expect them to show up along in the BTtoMQTT list? If so, now only devices which you have included in the white-list will be recognised and show there. So maybe you need to add them to the white-list as wll, if I understood you right

Go on your scale, go out and restart the esp32. You should see the sensor coming back in hass

Could you share a picture of the back please?

the issue was not so much about HA, and more about the devices that would show up under the HA heading in mqtt. in my frustration and since some of the changes i made when i initially set everything up made my setup not align with the instructions, i erased the esp32 and re uploaded the binaries, then pushed those tweaks i made with platformio, then went through the setup again on the chip. then when it started showing up in mqtt explorer, i waited until the 6 probes showed up then applied the whitelist, then removed all the devices that got discovered and sensors that got made in that short time, resulting in what i ultimately was looking for. the highlighted is what was missing in the previous post. i heated up one of the probes to make sure updates were still coming through after the whitelist change and confirmed that they were.

I must confess, the support i have received on here has been better than most of the vendors i deal with at work, and was a welcome surprise. It would seem that i am where i wanted to be now thanks to the both of you.

I see that there were more messages since i started typing this so i will try to provide all the pics i can.

and my pretty HA dashboard working :slight_smile:


Glad you got it working. Thanks for the pictures and Happy BBQ!