Can not connect to


Can not connect to Are getting faillure rc=5 please se below:

******** WELCOME TO OpenMQTTGateway **************
N: SSD1306 config initialised
[ 139][E][Preferences.cpp:483] getString(): nvs_get_str len fail: SSD1306Config NOT_FOUND
N: No SSD1306 config to load
N: Setup SSD1306 Display end
N: OpenMQTTGateway Version: v1.5.1
“mqtt_server”: “”,
“mqtt_port”: “1883”,
“mqtt_user”: “your_username”,
“mqtt_pass”: “your_password”,
“mqtt_topic”: “home/”,
“gateway_name”: “OpenMQTTGateway_lilygo_rtl_433_ESP”,
“mqtt_broker_secure”: false,
“mqtt_broker_cert”: “”,
“mqtt_ss_index”: 0,
“ota_server_cert”: “”,
“ota_pass”: “OTAPASSWORD”
}*wm:[2] Added Parameter: server
*wm:[2] Added Parameter: pass
*wm:[2] Added Parameter: secure
*wm:[2] Added Parameter: cert
*wm:[2] Added Parameter: name
*wm:[2] Added Parameter: topic
*wm:[2] Added Parameter: ota
N: Attempting Wifi connection with saved AP: 0
N: ZgatewayRTL_433 setup done
N: Switching to RTL_433 Receiver: 433.92Mhz
N: OpenMQTTGateway modules: [“LilyGo_SSD1306”,“rtl_433”]

N: ************** Setup OpenMQTTGateway end **************
W: MQTT connection…
W: failure_number_mqtt: 1
W: failed, rc=5
W: MQTT connection…
W: failure_number_mqtt: 2
W: failed, rc=5
W: MQTT connection…
W: failure_number_mqtt: 3
W: f

Best regards


I’m not advising using a public broker like
This will expose your data to public.

You can setup a local mosquito instance or use hivemq free plan if you prefer a free solution (requires encryption).

Yes you are right is not safe. However it should do for just a simple test of OpenMQTTGateway.

He has not a regular configuration see below:

Specifically the use of port 1884 when you have a username and a password.