DoCreate ESP32 Board Not Receiving RF


#1

Hi all,

I have a DoCreate ESP32 (same pinout as DOIT ESP32 Devkit V1) along with an SRX882 that I have previously used on a working ESP2866 gateway and it seems no matter which pin I use I am not receiving any RF. I have tried 13,27 and 22 - all nothing. I am using version .9 and my power supply tests out at 5V.

I have commented out all other protocols except for RF - when I had it enabled bluetooth was working.

Not sure what else to try…

One thing I am seeings is:
Leaving…
Hard resetting via RTS pin…

In the Arduino output pane after the sketch finishes uploading

Thanks

L.


#2

I reverted back to version 07 and it worked fine v08 and v09 don’t work - not sure why this would be… I left the V9 lib files in place as well so it is definitely the OMG code that is the difference.


#3

Turns out it is working - it just isn’t tracing RF messages to the serial console. I have mosquitto running in a docker and it doesn’t include mosquitto_sub so I couldn’t see the messages directly. I installed it on another box and I can see the messages coming through MQTT.


#4

I take that back - it was my ESP2866 messages I was seeing and the V.07 messages were just call backs from the other gateway!


#5

Hi,

if I understood well, all is working well or you need some support?


#6

RF isn’t working - I thought that it was due to my other gateway running on the same MQTT broker. I am now publishing to a newly created MQTT instance to avoid this while I test. Bluetooth is working fine and publishing, just no RF. I tested the receive pin running a blink test sketch and that worked fine, so I don’t think that it is the pin.


#7

And if you comment BT gateway do you get RF running?


#8

No, nothing I do will get it to work - I have commented out all other protocols and have tried several pins. The receiver I am using is one I used to use on my other gateway, but swapped it out for an RXB6 as I thought it would get better range. It was working fine in the other gateway. I also have a 315Mhz receiver and that one isn’t working either.


#9

And with the srx882 you didnt get it working ?


#10

The two receivers I am trying are both srx882’s (433/315) The RXB6 is currently in my working gateway…


#11

and your currently working gateway is with v0.7 isn’t it?


#12

Got it working receiving on PIN 27 - turned out my 433Mhz receiver was dead, but my 315MHz is working. Interestingly however sending 315Mhz doesn’t seem to be controlling my remote plug. I am pretty sure it is sending because I hear interference in my computer speakers while it sends, but the plug doesn’t turn on when I send it the correct codes.


#13

The plugs work when I set the delay to 315…


#14

Great, glad to hear that it works!