ESP32-C3, access point does not show up

I encountered a new issue with the Wemos Lolin C3 mini. Now I can no longer see its access point for the initial configuration. According to the log it should be there, log below. I cannot see the access point from other devices (laptop, cell phone), so I cannot configure the gateway. It happened after re-flashing it using the latest git development version. I tried erasing the flash.

Has anyone seen similar? How can I resolve it?

Is there another way to set the SSID/password of the home wifi? I found that I can configure MQTT and device name through build parameters. How about wifi?

Build:Feb  7 2021
rst:0x3 (RTC_SW_SYS_RST),boot:0xd (SPI_FAST_FLASH_BOOT)
Saved PC:0x40381a54
mode:DIO, clock div:1
entry 0x403cc710
************* WELCOME TO OpenMQTTGateway **************
N: OpenMQTTGateway Version: version_tag
N: Attempting Wifi connection with saved AP: 0
[   315][E][WiFiSTA.cpp:317] begin(): connect failed! 0x300a
N: Attempting Wifi connection with saved AP: 1
[  1317][E][WiFiSTA.cpp:317] begin(): connect failed! 0x300a
N: Attempting Wifi connection with saved AP: 2
[  2319][E][WiFiSTA.cpp:317] begin(): connect failed! 0x300a
N: Attempting Wifi connection with saved AP: 3
[  3321][E][WiFiSTA.cpp:317] begin(): connect failed! 0x300a
N: Attempting Wifi connection with saved AP: 4
[  4323][E][WiFiSTA.cpp:317] begin(): connect failed! 0x300a
N: Connect your phone to WIFI AP: OpenMQTTGateway with PWD: your_password
*wm:No wifi saved, skipping
*wm:AutoConnect: FAILED
*wm:StartAP with SSID:  OpenMQTTGateway
*wm:AP IP address:
*wm:Starting Web Portal

When scanning for wifis on another device (laptop, phone), no wifi OpenMQTTGateway shows up.

I can only suggest workarounds. Manual Wifi setup in the build should circumvent the error.


as Ilgrank has posted in a different thread. That should get you going.
I would also try to overwrite OMGs storage by flashing with a different partition scheme. A hello-world program built with

board_build.partitions = huge_app.csv

might help. Then try OpenMQTTGateway again.
I am also interested in how to specifically erase the Wifi / MQTT settings. See you.

Thanks. The manual configuration worked, now the device is back online.

Flashing got me nowhere. I tried erasing the flash entirely, flashing another programme in between. The AP never came back. Not sure why… very frustrating.

Agreed, I just had a rather unconventional idea. We have been experimenting with the indicators. There is the definition of the SetupIndicators() function which consists of several lines and is called at every startup of OMG. Try to go back to automatic Wifi configuration and temporarily insert (!) a line

      setup_wifimanager(true);   \

to the SetupIndicators. Run it once, reset or power off/on the board and look for it as an access point. Happy hacking, see you.

Creative idea, thanks for suggesting it! :slight_smile:

I wanted to verify that this AP issue wasn’t some odd side effect that was accidentally introduced by the NeoPixel changes. I couldn’t have seen how, but I just wanted to erase any possibility. I now run with the latest unchanged git version of OMG. I run into the same AP issue. As one would expect, the NeoPixel addition has nothing to do with it.

Could you try to erase with a different method like the one proposed below:

From my experience sometimes the erase functions do not work correctly.

I used: --port /dev/ttyACM3 --baud 921600 --before default_reset --after hard_reset erase_flash
Do you think this is insufficient?

It should be the most reliable but I would instead try a different method to remove a potential bad erase.

@argafal 1technophile’s link should run in a browser. I did not know about that Linux compatible tool before. I just tried to connect to my Seed Xiao, failed with Firefox, but succeed with Chromium. See you.