Github Boards Devices Community Docs Blog

ESP32-CAM compatibility

Hello,
I have tried to flash your firmware onto ESP32-CAM board with ESP-32S Ai-Thinker chip.
Is that posssible to use that board with OpenMqttGateway BLE gateway?

Also, Is there any manual how to prepare source code? I have tried that https://docs.openmqttgateway.com/upload/arduino-ide.html

Without any success. When I randomly changed some wifi settings the device connects to my network but the did not respond on IP:80 port.

Also, when I used clean source code, the device doesn’t boot with AP mode.

In the console I have seen that BLE scans was stopped, but I am not sure if there is any switch.
I have only edited files User_config.h and main.ino

Yes it should work as the board use an esp32

Omg doesn’t provide a webserver once connected to your network.
So as to verify that it is working you should connect to your broker with mqtt explorer.

You should only edit user_config.h with Arduino IDE.

I advise you to redownload the sources and edit user_config.h only. You may post it here if it doesn’t work.

Your messages are optimistic for me, and suprising in one time.
So, I will retry tomorrow. Thank you for your help :slight_smile:

Thank you for your help, but redownloading and making change in User_config.h doesn’t helped me. I have had changed line

//#define ZgatewayBT     "BT"       //ESP8266, ESP32

to

#define ZgatewayBT     "BT"       //ESP8266, ESP32

and commented other occurencies of #define Zgateway*** lines.
Also, I have tried to NOT modify User_config.h as mentioned in (cutting proto due to limitation on my account://docs.openmqttgateway.com/upload/arduino-ide.html) Change the settings and the desired gateways into User_config.h (uncomment the modules you want)

I have had tried to upload the code AS-IS after opening the main.ino file.

So, I would like to confirm, if all what I am trying to do do, to get webserver working after 1st start is proper, so I have had:

* First download the last version of the Arduino IDE from the arduino [website](https://www.arduino.cc/en/Main/Software)
* Add ESP32 boards by following this [tutorial](https://github.com/espressif/arduino-esp32/blob/master/docs/arduino-ide/boards_manager.md)
* Add ESP8266 boards by following this [tutorial](https://github.com/esp8266/Arduino#installing-with-boards-manager)

done as described

Download OpenMQTTGateway code (OpenMQTTGateway_sources.zip) from the release page and unzip it
Download the libraries package corresponding to your board and module wished into the same page (example esp32-m5stick-c-ble-libraries.zip) 

Downloaded https://github.com/1technophile/OpenMQTTGateway/releases/download/v0.9.5/esp32dev-ble-libraries.zip
and
https://github.com/1technophile/OpenMQTTGateway/releases/download/v0.9.5/OpenMQTTGateway_sources.zip

(maybe here I am doing something wrong?)

Extracted:
Screenshot in next post due to limitation on new user’s account :frowning:
3.

Change the pins or parameters corresponding to the modules choosen, for RF you can change the pins into config_RF.h

I have not changed nothing here as BLE is integrated in ESP32 board.


Choose the board on the Arduino IDE

I have Choosen AI-Thinker ESP32-CAM ![image|228x35]

Select the port corresponding to the board

Done, here are nothing complicated and the board with programmer and serial monitor worked properly.

but… here:

Note that for using BLE on ESP32 you will need to select Minimal SPIFFS into Tools->Partition Scheme

I have not find this option in Arduino IDE v1.8.42.0
Is that could cause my problem?

image

Next steps are clearly and working as Serial monitor prints the output with mqtt broker errors addressed in 192.168.1.17, even if I had hardcoded (replaced 192.168.1.17) it into the User_config.h:

#  define MQTT_SERVER "10.6.9.140"
#endif

Sorry for the lenght of this post :slight_smile:

Regarding 2nd point of my previous post, after extracting the files are as below:

Due to previous errors when I have had extracted contents of esp32dev-ble-libraries.zip directly into the libraries ( that time there was libraries\esp32dev-ble\ pattern)

Bump
Do anyone could check my steps?

You can choose ESP32 dev module and you will get the option