Github Boards Devices Community Docs Blog

Esp32-evb rf + bt

Hi,

I’m a bit new to this. I managed to get the BT working and reading my Xiaomi Temp+Humidity sensors but i have problem with the RF.

Current configuration:
Board: ESP-EVB (Olimex)
OMG version: 0.9.5
Ethernet connection over cable
RF: SRX882 / STX882
RF reciever gpio: 27 or 26
RF emitter gpio: 12
User_config #define ZgatewayRF is activated
Pin’s in config RF match reality.
Devices i tried to test: Chuango motion sensor, ELRO remote for electrical sockets, Chuango remote of alarm system.

Problem: i don’t see anything from RF passing trough MQTT (only BT or SYS)
Tried: other gpio’s but ethernet stops working when i do this and download sketch with other pin config.

Questions:

  • Are my gpio’s correct for this type of board?
  • Should this be possible with this board (BT + RF)?
  • Something else i need to adapt in configuration for RF?
  • Am i missing something (libraries?)
  • Other suggestions?

Thanks for shining some light for me :slight_smile:

Hi!

Should be OK unless these pins are used by the Olimex board for other purposes?

Could you check if the pins that you are using are free from other functions ?

If you are using GPIO 27 for receiver and 12 for emitter you don’t need

Did you took the libraries from the release page instead of the Arduino library manager ones

You could try v0.9.6 instead of v0.9.5

Hi,
thank you for your help @1technophile

When i checked the hardware i noticed that pins are also being used by the ethernet-port
https://github.com/OLIMEX/ESP32-EVB/raw/master/HARDWARE/REV-F/ESP32-EVB_Rev_F.pdf
I switched to wifi. I hope this solves this???
However nothing visual on MQTT explorer. i tried all RX ports already.

I made a little circuit that lights a led when signal is received (without board) ref: https://www.youtube.com/watch?v=KktetusdYxU
I noticed that i need to be very close with my 433 remote to make the receiver react. Basically less than10cm, antenna or no antenna makes no difference. I will first focus on soldering the antenna etc properly on the 433-receiver and place new batteries in remote. Maybe my original problem is also related to this. So soldering-set ordered. Let’s see next :slight_smile:

1 Like

Not sure it will solve the issue, I would try with pins that are not attached to any components