ESP32S3 - how to compile?

I try to compile the project with Arduino IDE (2.1.1 - Win64) - but no success.
The right processor was selected, the HELTEC JSON for the ESP32S3 stick loaded.

I get :
Compilation error: declaration of template parameter 'T' shadows template parameter

(same for other processor types …)

Any idea? Somebody have solved this?


Same issue here. Let me know if you manage compile it.

Any idea? Somebody have solved this?

Use platformio

:grinning: - Question was - how to compile it with Arduino as suggested here: :

… or build your own configuration with PlatformIO or Arduino IDE

There seems something not compatible with Arduino IDE.
With PIO it is working, agree…

May I ask, if there is a solution for this error?
First I was tinkering around with .bin and all works fine,
now I want to try Arduino IDE and getting the same error.

Edit: I tried PIO and there it works. But would be nice to get it running in Arduino IDE as well. :wink:

Unfortunately we are planning to remove the support for Arduino IDE as stated in the v1.7.0 release note.

For a noob like me PIO is much too much. But ok, so I have to
learn another thing to use, as everytime in life. :rofl:

Try it, at the end this is much easier than Arduino IDE as you don’t have to manage the libraries and platforms.

1 Like