ESP8266 + C1101 - loads fine with C1101 disconnected


I have a NodeMCUv3 with a C1101 hooked up like this:

2 VCC - WHITE - 3V3
3 GD00 - PURPLE - D2
5 SCK - BLACK - D5
6 MOSI - BLUE - D7
7 GD01\MISO - RED - D6
8 GD02 - BROWN - D3

(Ignore the colours, that is only for my reference of jumpers I am using).

I flash the board and it loads up fine, but when I have the C1101 module connected it doesn’t load up at all. A terminal connection shows that the output is all garbled. I’ve tried a number of baud rates as well, just to rule that out.

Here is a full log, you can see at the top what happens when I press the reset button on the board, it spits out a few characters then nothing. The end of this output shows what it looks like when the C1101 is not connected.

I tried with 2 different boards (unfortunately I only have 1 C1101 board to test with).

I am using this firmware: nodemcuv2-rf2-cc1101-firmware.bin downloaded from github and flashed via the NodeMCU flasher.

Command: --port COM7 --baud 115200 --after no_reset write_flash --flash_size detect --flash_mode dio 0x00000 C:\Users\Mark\Desktop\nodemcuv2-rf2-cc1101-firmware.bin --erase-all v3.0
Serial port COM7
Detecting chip type... ESP8266
Chip is ESP8266EX
Features: WiFi
Crystal is 26MHz
MAC: c8:c9:a3:5d:a3:9c
Uploading stub...
Running stub...
Stub running...
Configuring flash size...
Auto-detected Flash size: 4MB
Erasing flash (this may take a while)...
Chip erase completed successfully in 12.0s
Flash params set to 0x0240
Compressed 593264 bytes to 420108...
Wrote 593264 bytes (420108 compressed) at 0x00000000 in 37.2 seconds (effective 127.7 kbit/s)...
Hash of data verified.

Staying in bootloader.

Firmware successfully flashed. Unplug/replug or reset device 
to switch back to normal boot mode.```

Is this a hardware issue or am I doing something wrong?

Any pointers\suggestions to try and troubleshoot this is greatly appreciated!



Hi @markuslt

It could well be that the wiring might be wrong, due to the different versions of CC1101s around. Do you have a spec sheet confirming the pinouts of your CC1101, or could you post a picture of it here?

Sure! Here it is:

Purchased off of AliExpress… I read that there were some modules that had a different pinout but those references matched with the picture I posted above.

Thanks for your response! :slight_smile:

Yes, the same as I referenced here :slight_smile:

with these CC1101s easily recognised by the two large screw holes, the other models do not have.

So unless Aliexpress sent out a different model to what they stated on the product page, the wiring looks fine, apart from

• Have you tried it with GDO0 - RX, instead of your stated D2, as suggested as the default on the wiring instructions?

Yup, you got it! I have that one in the picture from your previous thread response. I tried on RX pin as suggested and the same behavior.

When connecting to the terminal after flashing I get this: bpp▒$blrl - it is pretty consistent in terms of those same characters being sent. I noted that when the CC1101 is not connected the terminal puts out human readable errors with regards to not being able to connect to the MQTT server. When it is in this state I can ping it on the network but not able to reach a web gui (not sure if i should be able to). As soon as I connect the C1101 and power it up, there is no network connection, the terminal is putting out that garbage and otherwise nothing works.

I am starting to wonder if it is hardware related… I might order a few more just to see.

thanks again for the support!

The WebUI is only implemented for ESP32, not ESP8266, so all is correct you not being able to reach it on your NodeMCU/ESP8266.

You might also want to try with an ESP32, if you have one at hand. Otherwise all the best with some replacement CC1101.

Thanks for your help! Using an ESP32 has gotten me to a functional device.