ESP8266+CC1101 not registering 433MHz signals

I am trying to get OMG to work with an ESP8266 (NodeMcu v3 CH340) using a CC1101-transceiver (E07-M1101D). I want to be able to send/receive signals like my Elro AB440R-433.92MHz Remote, though I have also tried with some other 433Mhz devices I had lying around and none seem to be picked up - neither in MQTT nor in serial monitor (also when setting ‘’-DCORE_DEBUG_LEVEL=4’‘or "-DLOG_LEVEL=LOG_LEVEL_TRACE’). I verified the supplied voltage to be 3.3V.

My configuration.ini file looks like this:

default_envs = nodemcuv2-rf2-cc1101-custom

extends = env:nodemcuv2-rf2-cc1101
build_flags =
  '-DMQTT_SERVER=""' ; Connects fine
  '-DRF_RECEIVER_GPIO=4' ;Receiver on D2 instead of D3 according to [the troubleshooting guide](
  '-DZradioCC1101="CC1101"' ;Not sure if this is necessary? 

Pins are connected according to the OMG-Docs CC1101-pinout:

  • GDO2 → D2 (After setting to D2/GPIO4 according to Troubleshooting guide)
  • GDO0 → RX (Also tried on D1/GPIO5)
  • SCK → D5
  • VCC → 3V3
  • MOSI → D7
  • MISO → D6
  • CSN → D8
  • GND → GND

Is there something obvious I’m doing wrong? Even when my devices are unsupported, I should be able to see something when setting DLOG_LEVEL, right?
Any suggestions for further troubleshooting are more than welcome!

I ended up trying the examples in this repository and only the RCSwitch-example (ReceiveDemo_Simple_cc1101.ino) seemed to work with my devices.

So I switched to nodemcuv2-rf-cc1101 instead of nodemcuv2-rf2-cc1101 for OMG and changed the pins to match that repository, using the default example ESP8266:


And now everything seems to work.