Github Boards Devices Community Docs Blog

ESP8266 with cc1101

So I’m trying to get OMG running on an old nodemcu v2 0.9 and cc1101 and I’m surprisingly lost

I’ve tried flashing nodemcuv2-rf-cc1101-firmware.bin and https://github.com/1technophile/OpenMQTTGateway/releases/download/v0.9.5/nodemcuv2-rf2-cc1101-firmware.bin (what’s the difference?)

esptool.py --port /dev/ttyUSB0 write_flash 0x0000 nodemcuv2-rf-cc1101-firmware.bin

It seems to be successful. I connect to it as an access point and then it connects to my WIFI/WLAN.

NodeRed now tells me that it’s receiving messages.

But…

It doesn’t seem to be making any attempts to connect to the cc1101.

When I probe the Dn pins (all of them), with my oscilloscope, none of them register any activity. No clock, no MOSI.

I also tried with platformio though the instructions for that route are unclear to me. No activity on the data pins with that upload either.

I’ve dorked around with this particular ESP device for other purposes and I don’t think I’ve killed the IOs.

I’m guessing I took a seriously wrong turn somewhere.

Please Help
Miles

I don’t have a lot of experience with CC1101, if another person with this module could jump on it would be great

I have been 100% successful using an CC1101/ESP32 and following this connection guide

When using the CC1101 I was compiling my own firmware, and supplied my own wiring definitions, but if your using prebuilt binaries you would need to wire like this