Flashing on an Tasmota device OTA?


#1

Hello All,

I’d like to experiment with OMG on my only device: RF Bridge. I have Tasmota on it and would like to know if anybody had any success flashing OMG OTA ? I’ve tried using the Tasmota OTA upgrade but it complains " Upload Failed Program flash size is larger than real flash size"

just wondering if the only way to flash it is to re open the box and connect the cables ?

thanks


Can sonoff RF bridge handle multiple MQTT messages published at the same time or in rapid succession?
#2

Could you post your build parameters from the ide please (tools menu screenshot), so as to check it?


#3

I have not built it, I’ve tried to use the binary from the release: https://github.com/1technophile/OpenMQTTGateway/releases/download/v0.9/SONOFF_RFBRIDGE_OpenMQTTGateway_V09.ino.bin.zip


#4

ok indeed in this case it can’t come from a bad ide parameter


#5

ok. I’ve finally built the binary file and that was accepted… the device rebooted and I could see OpenMQTTGatway wifi, I could log in, seen the web interface, entered the wifi parameters and… something happened. In some how it is not responsive anymore. Tried to reboot it (unplugging the cable) but still dead… ok, tomorrow I’ll try to open it, re plug the cables and re flash the official binary from the release.


#6

wow, strange ok I wait for your result


#7

I’ve eventually opened it and flashed the official binary. It works but it ignores all my click from my two remote control… Then I’ve read from https://github.com/1technophile/OpenMQTTGateway/wiki/User-guide-SRFB-09

NOTE: currently the device doesn’t receive correct values from Switches remote control

as I’m trying to control 4 switches (and more coming), I guess than I’m out of luck… so I’m testing Espurna now (as the device is open :slight_smile: )

thanks !


#8

ok… forget what I’ve said… apparently I’ve forgotten to turn ON the switch… now it works…

Probably it was working also when I did it OTA (when you do things in the night after a week of work)


#9

glad to see that it works