Gateway(s) not showing up in Home Assistant

Hi All,

Yesterday i moved from my external Debian MQTT broker to the add-on MQTT broker in Home Assistant.

So i had to change the MQTT broker ip on my ( 3 ) gateways, and change the MQTT client settings in Home Assistant.

I can see the OMG’s publishing with MQTT Explorer, everything looks the same as before.

Only thing is that the 3 OMG’s in Home Assistant where offline ( settings → integrations → MQTT ).

So i deleted them, and ever since i have do idea how i can get them back.

I only want to see the 3 OMG devices, no auto discovery for sensors etc.

Does anyone has an idea ?



Hi All,

Issue is solved :slight_smile:

First step:

Flash the gateways with following settings

; ‘-UZmqttDiscovery’ ; disables MQTT Discovery

After flashing the gateway is recognized by HomeAssistant

Then flash again but enable the ‘-UZmqttDiscovery’

‘-UZmqttDiscovery’ ; disables MQTT Discovery

This will disable the autodiscovery, but since the gateway(s) are now in HomeAssistant they will not be affected, any new device is not discovered.

One tip: if you wait too long between changing the settings you might end up with 433mhz devices in Home Assistant, delete them, after you disabled the autodiscovery they will not show up again.


Hi @Slorf,

Instead of having to reflash all your gateways twice, you could just turn off the discovery in the gateway settings :wink:

Since version 1.5.0 the auto-discovery is also being automatically switched off after 30 minutes.

Thanks !

I was running a older version, just upgraded to 1.5.1, will keep it in mind.