Github Upload Boards Devices Community Docs Blog

Help Intertechno and new Version

First of all i thank [Florian] 1technophile for the great Work.

Its bin over 4 Year that i flashed the first OpenMQTTGateway to my ESP-07.

Now i am upgrading my Smarthome, and the Broker Address has bin changed. So i had to build an new Gateway.

The last Years i switched my Intertechno PAR-1500.
My Topic / Message were: Topic: home/commands/PLSL_368/433_1/BITS_24 Message: 5242901 (Selector on D3)

But in the new Version an JSON is recommend, and i am not able to get the Projekt working.
Can anyone give me an example with the new Topic and Message.

My Envirenment: NodeMcu as Board, STX882, SRX882, HM10

In PIO i have set in User_conifg.h → #define ZgatewayRF and #define ZgatewayBT
in config_RF.h i also tryed defineRF_EMITTER_GPIO 4.

Thanks for Help Guys.

MARTIN

Hi!

Indeed the APi changed and now you can use json, I would suggest following this format:
https://docs.openmqttgateway.com/use/rf.html#send-data-by-mqtt-with-advanced-rf-parameters

In your case it will be:
'{"value":5242901,"protocol":1,"length":24,"delay":368}'

into:

home/OpenMQTTGateway/commands/MQTTto433

Thanks for the Help. But i dont get it working with this.

I figured out that i can send like the old Gatway with this Topic
home/OpenMQTTGateway/commands/MQTTto433/PLSL_368/433_1/RFBITS_24
so the only Thing i had to do is change the Topic.

THANKS now it works like charm. Hopefully even 4 Years to !!! :star_struck:

Glad to hear, for info we are going to remove this API in the next version, it would be great if you could use json.

For all Users the were using Openhab 3.

You can configure the JSON in the Channel under Advanced Settings like this.

{"value":%s,"protocol":1,"length":24,"delay":368}

The %s is the Value how changes.

Thanks to all.

Can be closed