Github Upload Boards Devices Community Docs Blog

HELP me with Environment list please!

Hi again,

I was playing with the IR gateway and wanted to add RF too.
This did work, except for the RTL_433 gateway. When I send the home/OpenMQTTGateway/commands/MQTTtoRTL_433 command {“active”:true} with the MQTT explorer I get no repond (which I do get when selecting RF2 or 433).

Therefore I’ve added some items to the environment list and now all the RF reception is gone…
Can anybody post the correct list for IR, RF2, 433, RTL433 and BT support with an ESP32 and CC1101 RF module?

My guess was:

[env:esp32-HUB]
platform = ${com.esp32_platform}
board = esp32dev
board_build.partitions = min_spiffs.csv
lib_deps =
${com-esp.lib_deps}
${libraries.ble}
${libraries.irremoteesp}
${libraries.smartrc-cc1101-driver-lib}
${libraries.rc-switch}
${libraries.rtl_433_ESP}
${libraries.newremoteswitch}
build_flags =
${com-esp.build_flags}
‘-DZgatewayRF=“RF”’
‘-DZgatewayRF2=“RF2”’
‘-DZgatewayIR=“IR”’
‘-DZgatewayBT=“BT”’
‘-DZgatewayPilight=“Pilight”’
‘-DZgatewayRTL_433=“rtl_433”’
‘-DZradioCC1101=“CC1101”’
‘-DGateway_Name=“OpenMQTTGateway_ESP32_HUB”’
‘-DvalueAsASubject=true’

Obviously there is a flaw in this list (I hope, otherwise I’m completely clueless).

Thanks a lot!

Hello,

I think you are missing the pilight library :

{libraries.esppilight}

You can refer to this example for RF multi receiver:

Thanks, I’ve added that , but still no RF reception at all.

I noticed that when I send <>MQTTtoRF2 or <>MQTTto433 as active=true that I get a confirmation from RF2toMQTT and 433toMQTT. But I do not get that when I send MQTTtoRTL_433 active=true:

OpenMQTTGateway
LWT = online
version = version_tag
▼commands
MQTTtoIR = {“hex”:“0xFFF00F”,“protocol_name”:“NEC”}
MQTTtoRF2 = {“active”:true}
MQTTtoRTL_433 = {“active”:true}
MQTTto433 = {“active”:true}
:arrow_forward:BTtoMQTT (5 topics, 34 messages)
IRtoMQTT = {“value”:16722135,“protocol”:3,“bits”:32,“hex”:“0xFF28D7”,“protocol_name”:“NEC”,“raw”:“9030,4600,514,636,508,610,536,612,508,638,636,506,512,610,510,632,514,610,534,1754,514,1754,510,1754,538,1752,514,1754,512,1752,540,1752,516,1752,512,634,512,608,538,1754,512,612,534,1756,510,612,536,610,510,636,510,1756,512,1752,540,634,486,1752,538,636,482,1754,540,1754,514,1752,512”}

SYStoMQTT = {“uptime”:244,“version”:“version_tag”,“freemem”:133040,“freestack”:4188,“rssi”:-55,“SSID”:“ASSY2.4”,“ip”:“172.16.51.149”,“mac”:“94:B9:7E:E5:47:E0”,“lowpowermode”:0,“btqblck”:0,“btqsum”:11,“btqsnd”:11,“btqavg”:1,“interval”:55555,“scanbcnct”:10,“scnct”:4,“actRec”:2,“mhz”:433.92,“modules”:[“IR”,“RF”,“RF2”,“Pilight”,“BT”]}

433toMQTT = {“active”:true}
RF2toMQTT = {“active”:true}

I also noticed during compyling with platformIO that I get quite some warnings, could that be the cause?

Library Manager: Installing build_flags
Warning! Could not find the package with ‘build_flags’ requirements for your system ‘windows_amd64’
Library Manager: Installing -w
Warning! Could not find the package with ‘-w’ requirements for your system ‘windows_amd64’
Library Manager: Installing true’
Warning! Could not find the package with ‘true’’ requirements for your system ‘windows_amd64’
Library Manager: Installing true’
Warning! Could not find the package with ‘true’’ requirements for your system ‘windows_amd64’
Library Manager: Installing true’
Warning! Could not find the package with ‘true’’ requirements for your system ‘windows_amd64’
Library Manager: Installing “HADiscovery”’
Warning! Could not find the package with ‘“HADiscovery”’’ requirements for your system ‘windows_amd64’
Library Manager: Installing 1’
Warning! Could not find the package with ‘1’’ requirements for your system ‘windows_amd64’
Library Manager: Installing ‘-DCONFIG_BT_NIMBLE_ROLE_PERIPHERAL_DISABLED’
Warning! Could not find the package with ‘’-DCONFIG_BT_NIMBLE_ROLE_PERIPHERAL_DISABLED’’ requirements for your system ‘windows_amd64’
Library Manager: Installing ‘-DCONFIG_BT_NIMBLE_ROLE_BROADCASTER_DISABLED’
Warning! Could not find the package with ‘’-DCONFIG_BT_NIMBLE_ROLE_BROADCASTER_DISABLED’’ requirements for your system
‘windows_amd64’
Library Manager: Installing ‘-DMQTTsetMQTT’
Warning! Could not find the package with ‘’-DMQTTsetMQTT’’ requirements for your system ‘windows_amd64’
Library Manager: Installing ‘-DMQTT_HTTPS_FW_UPDATE’
Warning! Could not find the package with ‘’-DMQTT_HTTPS_FW_UPDATE’’ requirements for your system ‘windows_amd64’
Library Manager: Installing “RF”’
Warning! Could not find the package with ‘“RF”’’ requirements for your system ‘windows_amd64’
Library Manager: Installing “RF2”’
Warning! Could not find the package with ‘“RF2”’’ requirements for your system ‘windows_amd64’
Library Manager: Installing “IR”’
Warning! Could not find the package with ‘“IR”’’ requirements for your system ‘windows_amd64’
Library Manager: Installing “BT”’
Warning! Could not find the package with ‘“BT”’’ requirements for your system ‘windows_amd64’
Library Manager: Installing “Pilight”’
Warning! Could not find the package with ‘“Pilight”’’ requirements for your system ‘windows_amd64’
Library Manager: Installing “rtl_433”’
Warning! Could not find the package with ‘“rtl_433”’’ requirements for your system ‘windows_amd64’
Library Manager: Installing “CC1101”’
Warning! Could not find the package with ‘“CC1101”’’ requirements for your system ‘windows_amd64’
Library Manager: Installing “OpenMQTTGateway_ESP32_HUB”’
Warning! Could not find the package with ‘“OpenMQTTGateway_ESP32_HUB”’’ requirements for your system ‘windows_amd64’
Library Manager: Installing true’
Warning! Could not find the package with ‘true’’ requirements for your system ‘windows_amd64’
Library Manager: Installing true’
Warning! Could not find the package with ‘true’’ requirements for your system ‘windows_amd64’
Library Manager: Installing 4’
Warning! Could not find the package with ‘4’’ requirements for your system ‘windows_amd64’
Found 40 compatible libraries

After starting with a fresh file and creating a new environment without copy-paste of the old one, the build warnings are gone. Probably the copy-paste of the text was not OK and contained hidden characters or something.

Too bad it did still not solve the RF receiving issue… now even the IR reception doesn’t work anymore. Let’s quit for today…

When I upload the default esp32dev-ir from the web, the IR works and the ESP32 wifi connection is stable.

But when I upload my own configuration, wifi becomes unstable (although I configure it in the same way) and nothing works anymore…

These are the only changes I’ve made:

In user_config.h I have uncommented:
#define ZgatewayRF “RF” //ESP8266, Arduino, ESP32
#define ZgatewayIR “IR” //ESP8266, Arduino, Sonoff RF Bridge
#define ZgatewayPilight “Pilight” //ESP8266, Arduino, ESP32
#define ZgatewayBT “BT” //ESP8266, ESP32
#define ZgatewayRF2 “RF2” //ESP8266, Arduino, ESP32
#define ZmqttDiscovery “HADiscovery”//ESP8266, Arduino, ESP32, Sonoff RF Bridge
#define ZradioCC1101 “CC1101” //ESP8266, ESP32

In platformio.ini I have added this environment:
default_envs = esp32dev-HUB

[env:esp32dev-HUB]
platform = ${com.esp32_platform}
board = esp32dev
board_build.partitions = min_spiffs.csv
lib_deps =
${com-esp.lib_deps}
${libraries.irremoteesp}
${libraries.ble}
${libraries.rc-switch}
${libraries.smartrc-cc1101-driver-lib}
${libraries.rtl_433_ESP}
${libraries.esppilight}
${libraries.newremoteswitch}
build_flags =
${com-esp.build_flags}
‘-DZgatewayIR=“IR”’
‘-DZgatewayBT=“BT”’
‘-DZgatewayRF=“RF”’
‘-DZgatewayRF2=“RF2”’
‘-DZgatewayRTL_433=“RTL_433”’
‘-DZgatewayPilight=“Pilight”’
‘-DZradioCC1101=“CC1101”’
‘-DGateway_Name=“OpenMQTTGateway_HUB”’
‘-DvalueAsASubject=true’

If there only was a default web config for a IR, BT, RF, RF2 and RTL_433 gateway…

What am I missing here???

Hi,

There is chance that the esp32 doesn’t have enough memory to support all these gateways together.
I would remove some if you think you can or either try to tuneup the libraries so that they request less memory. Like removing protocols.
You can have a view on the remaining memory on the regular published information into SYStoMQTT topic.

Again a great suggestion, so I’ve removed the BT and the wifi is stable + IR works.
Switching between RF receivers now also gives echo on all receiver options.

Only there is no RF reception/MQTT message on any signal (I’ve tried 433 and RF2).
Transmitting RF works fine (only tested with RF2 now).
Could it be that my CC1101 has partially died or is it not configured in the right way?

The SYStoMQTT does not show the CC1101 (don’t know if it should be there at all):
SYStoMQTT = {“uptime”:122,“version”:“version_tag”,“freemem”:114684,“freestack”:4248,“rssi”:-58,“SSID”:“xxxx”,“ip”:“xx.xx.xx.xx”,“mac”:“xx:xx:xx:xx:xx:xx”,“actRec”:3,“mhz”:433.92,“RTLminRssi”:-82,“RTLRssi”:-83,“RTLCnt”:32,“modules”:[“IR”,“RF”,“RF2”,“Pilight”,“RTL_433”]}

Maybe @NorthernMan54 can help on this one?

One thing I found with my devices was that the reception range of the CC1101 was significantly shorter than a USB SDR and other receiver types. Have you tried within 6 feet of a transmitter ?

And with some people’s devices we have seen this issue - rtl_433_Callback stops receiving messages · Issue #16 · NorthernMan54/rtl_433_ESP · GitHub . Which appears to be an within the device itself.

Yes, the CC1101 and transmitters are less than 2 ft apart when I test.
In the meantime I have exchanged the CC1101 and that solves it for the 433 reception, so obviously the other CC1101 was damaged.
But still RF2 and RTL_433 reception do not work, although switching between the receivers seems to work (at least when I put it on RF2 I do not receive any 433; which I do when I switch it back to 433 receiver).
I however noticed that when I selected Pilight receiver it reacted on RF2 signals! With my ESP8266 the KAKU signal was received as RF2 where it is now received as Pilight…

I did get 433 and RF2 to work on my ESP8266 with the CC1101, but I had to swtich over to the ESP32 since I want to add RTL_433 support too.

Is there any SDR transceiver that you can recommend using? I can live without the bluetooth support for now, but I need all kinds of RF transmitting (433 and RF2) and at least receiving of RTL_433…
I’m so close…