Home Assistant mqtt discovery does not work as expected


#1

Hi there,

Now to fun part begins. I turn on the mqtt auto discovery for my plenty of mi flora bluetooth plant sensors. But I do not see the sensors comming up in Home Assistant.

The log says the following:
2019-01-18 09:27:56 INFO (MainThread) [homeassistant.components.mqtt.discovery] Component has already been discovered: binary_sensor 30AEA44E8B08, sending update
2019-01-18 09:27:56 INFO (MainThread) [homeassistant.components.mqtt] Got update for entity with hash: (‘binary_sensor’, ‘30AEA44E8B08’) ‘{‘state_topic’: ‘home/OpenMQTTGatewayBLT/LWT’, ‘name’: ‘OpenMQTTGatewayBLT’, ‘unique_id’: ‘30AEA44E8B08’, ‘device_class’: ‘connectivity’, ‘payload_on’: ‘online’, ‘payload_off’: ‘offline’, ‘optimistic’: False, ‘retain’: True, ‘payload_available’: ‘online’, ‘payload_not_available’: ‘offline’, ‘platform’: ‘mqtt’, ‘discovery_hash’: (‘binary_sensor’, ‘30AEA44E8B08’)}’
2019-01-18 09:27:56 INFO (MainThread) [homeassistant.components.mqtt] Updating component: binary_sensor.openmqttgatewayblt
2019-01-18 09:27:56 INFO (MainThread) [homeassistant.components.mqtt.discovery] Component has already been discovered: sensor 30AEA44E8B08gatewayBT, sending update
2019-01-18 09:27:56 INFO (MainThread) [homeassistant.components.mqtt] Got update for entity with hash: (‘sensor’, ‘30AEA44E8B08gatewayBT’) ‘{‘state_topic’: ‘home/OpenMQTTGatewayBLT/BTtoMQTT/’, ‘name’: ‘gatewayBT’, ‘unique_id’: ‘30AEA44E8B08gatewayBT’, ‘value_template’: ‘{{ value_json.message }}’, ‘optimistic’: False, ‘retain’: False, ‘device’: {‘name’: ‘OpenMQTTGatewayBLT’, ‘manufacturer’: ‘OMG_community’, ‘sw_version’: ‘0.9beta’, ‘identifiers’: [‘30AEA44E8B08’]}, ‘platform’: ‘mqtt’, ‘discovery_hash’: (‘sensor’, ‘30AEA44E8B08gatewayBT’)}’
2019-01-18 09:27:56 INFO (MainThread) [homeassistant.components.mqtt] Updating component: sensor.gatewaybt
2019-01-18 09:27:58 WARNING (MainThread) [homeassistant.components.binary_sensor.mqtt] No matching payload found for entity: Kamer Sensor with state_topic: home/433toMQTT

But I see only the following in HA:
binary_sensor.openmqttgatewayblt on friendly_name: OpenMQTTGatewayBLT device_class: connectivity

Now the big questoin how can we debug. I have tested the mqtt with the following:


And the example garden sensor shows up in HA.

I’m willing to help you guys how to fix this.


#2

Hello,

Could you post your user_config.h without credentials please?


#3

/*
OpenMQTTGateway - ESP8266 or Arduino program for home automation

Act as a wifi or ethernet gateway between your 433mhz/infrared IR signal and a MQTT broker
Send and receiving command by MQTT

This program enables to:

  • receive MQTT data from a topic and send signals corresponding to the received MQTT data

  • publish MQTT data to a different topic related to received signals

    Copyright: ©Florian ROBERT

    This file is part of OpenMQTTGateway.

    OpenMQTTGateway is free software: you can redistribute it and/or modify
    it under the terms of the GNU General Public License as published by
    the Free Software Foundation, either version 3 of the License, or
    (at your option) any later version.

    OpenMQTTGateway is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
    GNU General Public License for more details.

    You should have received a copy of the GNU General Public License
    along with this program. If not, see http://www.gnu.org/licenses/.
    /
    /
    -------------------VERSION----------------------*/
    #define OMG_VERSION “0.9beta”

/-------------CONFIGURE WIFIMANAGER-------------(only ESP8266 & SONOFF RFBridge)/
/*

  • The following parameters are set during the WifiManager setup process:
    • wifi_ssid
    • wifi_password
    • mqtt_user
    • mqtt_pass
    • mqtt_server
    • mqtt_port
  • To completely disable WifiManager, define ESPWifiManualSetup.
  • If you do so, please don’t forget to set these variables before compiling
  • Otherwise you can provide these credentials on the web interface after connecting
  • to the access point with your password (SSID: WifiManager_ssid, password: WifiManager_password)
    */

/-------------DEFINE YOUR NETWORK PARAMETERS BELOW----------------/
#if defined(ESP8266) // for nodemcu, weemos and esp8266
//#define ESPWifiManualSetup true //uncomment you don’t want to use wifimanager for your credential settings on ESP
#endif

#if defined(ESP32) || defined(ESPWifiManualSetup) // for nodemcu, weemos and esp8266
#define wifi_ssid “Marrol”
#define wifi_password “********************”
#else // for arduino + W5100
const byte mac[] = { 0xDE, 0xED, 0xBA, 0xFE, 0x54, 0x95 }; //W5100 ethernet shield mac adress
#endif

#define WifiManager_password “your_password” //this is going to be the WPA2-PSK password for the initial setup access point
#define WifiManager_ssid “OpenMQTTGateway” //this is the network name of the initial setup access point

/-------------DEFINE YOUR MQTT PARAMETERS BELOW----------------/
//MQTT Parameters definition
//#define mqtt_server_name “www.mqtt_broker.com” // instead of defining the server by its IP you can define it by its name, uncomment this line and set the correct MQTT server host name
char mqtt_user[20] = “admin”; // not compulsory only if your broker needs authentication
char mqtt_pass[30] = “***************”; // not compulsory only if your broker needs authentication
char mqtt_server[40] = “192.168.1.190”;
char mqtt_port[6] = “1883”;

#define Gateway_Name “OpenMQTTGatewayBLT”

//uncomment the line below to integrate msg value into the subject when receiving
//#define valueAsASubject true

/-------------DEFINE THE MODULES YOU WANT BELOW----------------/
//Addons and module management, comment the Z line

//#define ZgatewayRF “RF” //ESP8266, Arduino, ESP32
//#define ZgatewayRF315 “RF315” //ESP8266, Arduino, ESP32
//#define ZgatewayIR “IR” //ESP8266, Arduino, Sonoff RF Bridge
//#define ZgatewayPilight “Pilight” //ESP8266, Arduino, ESP32
#define ZgatewayBT “BT” //ESP8266, Arduino, ESP32
//#define ZgatewayRF2 “RF2” //ESP8266, Arduino, ESP32
//#define ZgatewaySRFB “SRFB” // Sonoff RF Bridge
//#define Zgateway2G “2G” //ESP8266, Arduino, ESP32
//#define ZactuatorONOFF “ONOFF” //ESP8266, Arduino, ESP32, Sonoff RF Bridge
//#define ZsensorINA226 “INA226” //ESP8266, Arduino, ESP32
//#define ZsensorHCSR501 “HCSR501” //ESP8266, Arduino, ESP32, Sonoff RF Bridge
//#define ZsensorADC “ADC” //ESP8266, Arduino, ESP32
//#define ZsensorBH1750 “BH1750” //ESP8266, Arduino, ESP32
//#define ZsensorTSL2561 “TSL2561” //ESP8266, Arduino, ESP32
//#define ZsensorBME280 “BME280” //ESP8266, Arduino, ESP32
//#define ZsensorDHT “DHT” //ESP8266, Arduino, ESP32, Sonoff RF Bridge
//#define ZgatewayRFM69 “RFM69” //ESP8266, Arduino, ESP32
//#define ZsensorGPIOKeyCode “GPIOKeyCode” //ESP8266, Arduino, ESP32
//#define ZsensorGPIOInput “GPIOInput” //ESP8266, Arduino, ESP32
#define ZmqttDiscovery “HADiscovery”//ESP8266, Arduino, EPS32, Sonoff RF Bridge

/-------------DEFINE YOUR ADVANCED NETWORK PARAMETERS BELOW----------------/
//#define MDNS_SD //uncomment if you want to use mdns for discovering automatically your ip server, please note that MDNS with ESP32 can cause the BLE to not work
//#define cleanFS true //uncomment if you want to clean the ESP memory and reenter your credentials
#define maxMQTTretry 4 //maximum MQTT connection attempts before going to wifi setup

//set minimum quality of signal so it ignores AP’s under that quality
#define MinimumWifiSignalQuality 8

// these values are only used if no dhcp configuration is available
const byte ip[] = { 192, 168, 1, 99 }; //ip adress
const byte gateway[] = { 0, 0, 0, 0 }; //ip adress, if first value is different from 0 advanced config network will be used and you should fill gateway & dns
const byte Dns[] = { 0, 0, 0, 0 }; //ip adress, if first value is different from 0 advanced config network will be used and you should fill gateway & dns
const byte subnet[] = { 255, 255, 255, 0 }; //ip adress

/-------------DEFINE YOUR MQTT ADVANCED PARAMETERS BELOW----------------/
#define Base_Topic “home/”
#define version_Topic Base_Topic Gateway_Name “/version”
#define will_Topic Base_Topic Gateway_Name “/LWT”
#define will_QoS 0
#define will_Retain true
#define will_Message “offline”
#define Gateway_AnnouncementMsg “online”

#define jsonPublishing true //comment if you don’t want to use Json publishing (one topic for all the parameters)
//example home/OpenMQTTGateway_ESP32_DEVKIT/BTtoMQTT/4XXXXXXXXXX4 {“rssi”:-63,“servicedata”:“fe0000000000000000000000000000000000000000”}
#define jsonReceiving true //comment if you don’t want to use Json reception analysis

//#define simplePublishing true //comment if you don’t want to use simple publishing (one topic for one parameter)
//example
// home/OpenMQTTGateway_ESP32_DEVKIT/BTtoMQTT/4XXXXXXXXXX4/rssi -63.0
// home/OpenMQTTGateway_ESP32_DEVKIT/BTtoMQTT/4XXXXXXXXXX4/servicedata fe0000000000000000000000000000000000000000
#define simpleReceiving true //comment if you don’t want to use old way reception analysis

/-------------DEFINE YOUR OTA PARAMETERS BELOW----------------/
#define ota_hostname Gateway_Name
#define ota_password “OTAPASSWORD”
#define ota_port 8266

/-------------DEFINE PINs FOR STATUS LEDs----------------/
#define led_receive 40
#define led_send 42
#define led_error 44

// VCC ------------D|-----------////\ ----------------- Arduino PIN
// LED Resistor 270-510R

/----------------------------OTHER PARAMETERS-----------------------------/
/-------------------CHANGING THEM IS NOT COMPULSORY-----------------------/
/----------------------------USER PARAMETERS-----------------------------/
#ifdef ZgatewaySRFB
#define SERIAL_BAUD 19200
#else
#define SERIAL_BAUD 115200
#endif
/--------------MQTT general topics-----------------/
// global MQTT subject listened by the gateway to execute commands (send RF, IR or others)
#define subjectMQTTtoX Base_Topic Gateway_Name “/commands/#”
#define subjectMultiGTWKey “toMQTT”
#define subjectGTWSendKey “MQTTto”

//variables to avoid duplicates
#define time_avoid_duplicate 3000 // if you want to avoid duplicate mqtt message received set this to > 0, the value is the time in milliseconds during which we don’t publish duplicates

//uncomment to use multicore function of ESP32 for BLE
#ifdef ESP32
#define multiCore //comment to don’t use multicore function of ESP32 for BLE
#endif

#define JSON_MSG_BUFFER 512 // Json message max buffer size, don’t put 1024 or higher it is causing unexpected behaviour on ESP8266

#define TimeBetweenReadingSYS 120000 // time between system readings (like memory)
#define subjectSYStoMQTT Base_Topic Gateway_Name “/SYStoMQTT”

/-------------------ACTIVATE TRACES----------------------/
#define TRACE 1 // commented = trace off, uncommented = trace on


#4

See above the requested file, I have looked into the zmqttdiscovery.ino and i see the following:

#ifdef ZgatewayBT
// Sensor to display RF received value
trc(F(“gatewayBTDiscovery”));
char * gatewayBT[8] = {“sensor”, “gatewayBT”, “”, “”,"{{ value_json.message }}","", “”, “”};

values_json.message is that a variable, it doenst look like it. Because I see this text also in the logs of home assistant. I was expected that this text wil be replace by an actual json string.