Install on ESP32-C3 Super Mini

I obtained a ESP32-C3 for the BLE 5 capability. ESP32-C3 Development Board ESP32 C3 SuperMini WiFi Bluetooth For Arduino ( I tried the web install and nothing happened. I did use the web install from my original Heltec board with success. I also tried with the second option to load V1.7 binaries using the espressif tools. I was able to interact with the tool to erase and to load firmware. This process went without issue, but after the install the ESP32-C3 just stayed in a reboot loop. I tried with two of them. I also tried 40 Mhz and 80 Mhz and also DoNotChgBin in both states with the same result. A typical log is

Uploading stub...
Running stub...
Stub running...
Changing baud rate to 115200
test offset :  57344 0xe000
case ok
test offset :  4096 0x1000
case ok
test offset :  65536 0x10000
case ok
test offset :  32768 0x8000
case ok

Uploading stub...
Running stub...
Stub running...
Changing baud rate to 115200
Compressed 17440 bytes to 12090...
Compressed 3072 bytes to 146...
Compressed 8192 bytes to 47...
Compressed 1611920 bytes to 898541...

 is stub and send flash finish

I can use the Web installer for WLED and successfully load WLED onto the new C3 board. Could this be an unsupported board and if so, is there a small form-factor C3 that is recommend?

You need to check serial log

hi I have the same problem as you, the card is not recognized, too bad

Try compile without BLE or extra features.
Just for testing

I tried the two C3 builds that were available. The second one being the lolin c3 mini. Same result.

Where is the serial log placed when doing the web install?

i just bought one of these (was going to use it with esphome, but now want to use it with OMG) and get the same “Your Unknown Chip board is not supported.
OpenMQTTGateway: Unknown Chip” when trying to flash via the web page.

are we just SOL here or is there something not being done correctly? it would be REAL useful to have such a small and neat device in use

I have had success loading WLED on C3, but no success with OMG and Espresense. Even using Espressif tools fails to load OMG.

weird, I just tried on esphome and it saw it and installed the firmware to it with zero complaint. :frowning:

I have an M5Stamp C3 and tried it below:

Works for me, try maybe to start with the environment in the PR and remove the unnecessary macro like trigger and led

I need a little help with the lingo “Works for me, try maybe to start with the environment in the PR and remove the unnecessary macro like trigger and led”

What specifically do I need to try if I am loading from the OMG browser page with the available binaries?

Are you referring to recompiling from source to remove certain content?

Another observation I made is that when I load C3 with OMG then it will never startup normally. To talk to the hardware again, I need to hold the boot button at power up so it is listening.

where can we download this c3 m5stamp dev firmware? I can see it listed in the web installer, but obviously that doesn’t work. I’d like to try to install it via esp flasher

don’t worry, I checked the source of the page and downloaded them based off of the locations in the json. Pushed them all to the esp via flasher using the normal documented hex codes but it still finished with “is stub and send flash finish” whatever that means, and the result is a boot loop (windows keeps making the disconnected noise every couple seconds.)

just fyi, Florian has added a c3 section in the drop down. give it a try, its working with mine now :slight_smile: (Option 1) Upload from the web | OpenMQTTGateway DEVELOPMENT SHA:8fa47d TEST ONLY

Unfortunately, no luck with my C3 super mini. I tried all images in the C3 section. They load, but seems they do not vector to boot sequence on reset or repower. There is no SSID Wifi being broadcast. One red LED which seems to indicate power applied. At times I see a blue LED illuminate for about 5 seconds every minute or two.

After loading and selecting the console option, there is no feedback until I select Reset Device. It then shows the following and then nothing else

Build: Feb 7 2021
rst:0x15 (USB_UART_CHIP_RESET), boot:0x5 (DOWNLOAD(USB/UART0/1))
Saved PC:0x400462e0
waiting for download

just want to confirm that my esp32 c3 super mini is now working like a breeze with this dev-URL. Upload worked without error and I didn’t have to press boot or any other button. Wifi AP is spawned and I could enter my ssid and mqtt details.
Thanx Forian, awesome product!


can I ask what model firmware you flashed with as I’m having loads of issues with mine now. it just seems to drop back into AP mode and when I go to re-set it up again it seems to have forgotten all of the settings previously given to it.

hope that helps:



uptime 50969
version “24e3ef”
env “esp32c3-dev-m1-ble”

brgds, Martin

P.S. I switched the module of and on. It reconnects w/o problem.

Reupload from the development branch, a former commit had an issue with the bootloader

i reflashed a couple of hours ago, will that be on the fixed fw or do i need to do it again?