Github Devices Community Docs Blog

Latest OpenMQTTGateway how to?

i want to make my own cheap (Infrared IR, 433mhz and MQTT on ESP8266 bidirectional gateway using OpenMQTTGateway )

i want all those in one unit , so i got this link https://1technophile.blogspot.com/2016/11/433nIRtomqttto433nIR-bidirectional-esp8266.html

but this link is old and the latest releases on github of openmqttgateway does not provide this all in one bin file for esp8266,

how to upload the latest software of this project to my esp8266 board ?

Hello,

the best way is to configure and upload the program with platformio.

I can also upload a bin file following your needs but the first method should be tried first.

I m unable to use the platformio method , i m very new to it ,

Is there any tutorial on how to install and use platform ?

Here is it:

sorry for late reply .

i tried as it is in this video , but i do get many errors , i am unable to flash the code to my esp32 with the given circuit ,

please give a tutorial ,

Hello,

Do you want to flash an esp32 or an esp8266 ?

i want to flash to esp8266 nodemcu .

i have build the circuit according to this schematic

As a first try and if you can change your pinout to the default one you could try to flash a pre built binary :
http://docs.openmqttgateway.com/#/upload/binaries

which binary should i download for esp8266 with both RF and IR ?

when i try to build the code in platformio then it gives this error

LibraryManager: Installing WiFiManager
UserSideException: Please install Git client from https://git-scm.com/downloads:
  File "C:\Users\elitebook\.platformio\penv\lib\site-packages\platformio\builder\main.py", line 126:
    env.SConscript("$BUILD_SCRIPT")
  File "C:\Users\elitebook\.platformio\packages\tool-scons\script\..\engine\SCons\Script\SConscript.py", line 541:
    return _SConscript(self.fs, *files, **subst_kw)
  File "C:\Users\elitebook\.platformio\packages\tool-scons\script\..\engine\SCons\Script\SConscript.py", line 250:
    exec _file_ in call_stack[-1].globals
  File "C:\Users\elitebook\.platformio\platforms\espressif8266\builder\main.py", line 316:
    target_elf = env.BuildProgram()
  File "C:\Users\elitebook\.platformio\packages\tool-scons\script\..\engine\SCons\Environment.py", line 224:
    return self.method(*nargs, **kwargs)
  File "C:\Users\elitebook\.platformio\penv\lib\site-packages\platformio\builder\tools\platformio.py", line 122:
    _build_project_deps(env)
  File "C:\Users\elitebook\.platformio\penv\lib\site-packages\platformio\builder\tools\platformio.py", line 47:
    project_lib_builder = env.ConfigureProjectLibBuilder()
  File "C:\Users\elitebook\.platformio\packages\tool-scons\script\..\engine\SCons\Environment.py", line 224:
    return self.method(*nargs, **kwargs)
  File "C:\Users\elitebook\.platformio\penv\lib\site-packages\platformio\builder\tools\piolib.py", line 1043:
    project.install_dependencies()
  File "C:\Users\elitebook\.platformio\penv\lib\site-packages\platformio\builder\tools\piolib.py", line 878:
    lm.install(uri)
  File "c:\users\elitebook\.platformio\penv\lib\site-packages\platformio\managers\lib.py", line 359:
    force=force)
  File "c:\users\elitebook\.platformio\penv\lib\site-packages\platformio\managers\package.py", line 701:
    track=True)
  File "c:\users\elitebook\.platformio\penv\lib\site-packages\platformio\managers\package.py", line 486:
    vcs = VCSClientFactory.newClient(tmp_dir, url)
  File "c:\users\elitebook\.platformio\penv\lib\site-packages\platformio\vcsclient.py", line 49:
    silent)
  File "c:\users\elitebook\.platformio\penv\lib\site-packages\platformio\vcsclient.py", line 63:
    self.check_client()
  File "c:\users\elitebook\.platformio\penv\lib\site-packages\platformio\vcsclient.py", line 130:
    "Please install Git client from https://git-scm.com/downloads")
=========================================================================== [FAILED] Took 4.89 seconds ===========================================================================

Environment        Status    Duration
-----------------  --------  ------------
rfbridge           IGNORED
esp32dev-all       IGNORED
esp32dev-rf        IGNORED
esp32dev-ir        IGNORED
esp32dev-ble       IGNORED
ttgo-lora32-v1     IGNORED
nodemcuv2-all      IGNORED
nodemcuv2-ble      IGNORED
nodemcuv2-ir       IGNORED
nodemcuv2-rf       FAILED    00:00:04.895
rf-wifi-gateway    IGNORED
nodemcuv2-rf2      IGNORED
nodemcuv2-pilight  IGNORED
sonoff-basic-rfr3  IGNORED
atmega-all         IGNORED
uno-rf             IGNORED
uno-fastled        IGNORED
===================================================================== 1 failed, 0 succeeded in 00:00:04.895 =====================================================================
The terminal process terminated with exit code: 1

Terminal will be reused by tasks, press any key to close it.

You can try first with rf or ir. I will give you next week with both if you succeed like that with one of them.

Just do what it is saying.