LilyGo 433 Board - sees Access Point, but will not connect?

I’m stumped and could use some debugging suggestions please. I have a working LilyGo 433Mhz board that’s been working great for a few months. Yesterday, I moved the board from one access point, to a new one – and the board refuses to connect to the new AP.

The board’s WiFi manager can see the new AP, but upon reboot, I get the message “AP Not Found”.

This second AP, “CONROY31FK” is working. I have many other devices connected to it. My laptops can connect to it, my phone will connect. The LilyGo refuses to connect for some reason.

The second AP is Raspberry Pi based. I have an RPi configured as this AP, if that has something to do with it.

Any ideas on why other devices will connect to the new AP, and the LilyGo board can see the new AP, but refuses to connect? Something V4 or V6 maybe??? I’m stumped and would like to know if there’s a way to get additional debugging information off the LilyGo board when it’s trying to connect.


What software are you running on the Pi?
Is there anything in the logs on the Pi and the Lilygo?

Standard “wpa_supplicant” stuff on the Pi. The internal WiFI is the AP on the Pi. Nothing in the Pi logs for “wlan0”. I can up the debug level for wpa_supplicant and retry but it’s like the LilyGo doesn’t even try.

I’m not sure how long (duration in seconds) the OMG looks for an AP, but it sure seems like the LilyGo gives up quickly.

I don’t know how to enable logging on the OMG side of things. Or where to look. I don’t know if there are compile flags to set that’ll push debug info to somewhere the WebUI can get to?


I brought everything inside, connected it to minicom, and added a debug line to OMG to display the status after attempting to connect to the new AP. It’s ERROR 1 - which is “WL_NO_SSID_AVAIL”. Which is odd.

It’s fast too - it tries for a very short amount of time (like a second or so) before giving up on the new AP. I think it sees the new AP but doesn’t like something about the way it’s configured. And gives up.

There are a ton of google hits on this topic with the ESP8266 and ESP32. I’m going to pull out another ESP32 board and do some more debugging.

Hi Patrick, how’d you go with other boards?

Thanks for asking. I work on this in between sixteen other things on my to-do list. :slight_smile:

I did have another ESP32 board and it does the same thing. So there’s something in-between the RPi and the ESP board. This is using the built-in WiFi (Broadcom) chip on a 3B+. All of my other non-ESP devices can easily connect to the RPi. The ESP32 can easily connect to any other AP in the house. It’s just the ESP32 doesn’t like the RPi AP. I end up with a 201 error after a few seconds. There’s something in the handshake that it doesn’t like.

On my to-do list:

  • goof with the various security protocols on the AP. I tried None/Open and the ESP32 still didn’t connect. I’ll try WPA3
  • update the firmware on the RPi. Did that but haven’t tried it
  • stop using the built-in Broadcom WiFi as the AP, switch to a USB WiFi dongle and see if there’s something about the Broadcom chip that’s giving me trouble

It’s weird and since I’m not a WiFi/network guy all I’m doing to changing stuff/rebooting and trying it again.

Note that the ESP only runs on 2.4Ghz, but some things to try…

  1. Use WiFiAnalyser on your phone to see which band (2.4Ghz and 5Ghz) and channel your AP is on. … I just found out that there’s also a PC version…
  2. You could run something like Wireshark on a PC to see the whole connection stuff happening.
  3. Check your country setting because different channels are used in different countries.
  4. I think you’ve tried it, but the security might still be an issue.

Good suggestions - thank you.
I >>suspect<< it’s not a band issue as the ESP32 has no problem finding and seeing the RPi AP. It appears when WiFi.scanNetworks() is called.

Just doesn’t want to connect.

Mods - since this appears to NOT be an OMG issue, shall I continue to post results here? Or should we delete the thread?

Or just leave it as it?


Hi @Patrick_Conroy,

would you mind testing with the previous platform? In platformio.ini change the line

esp32_platform = espressif32@6.1.0


esp32_platform = espressif32@3.5.0

and let us know if it makes a difference.

Hi DigiH - I switched over the an ESP32 that was not loaded with OMG as it became apparent to me this wasn’t an OMG issue.

I’ve finally had a few minutes to play with this some more and I’ve made some progress. When I updated the RPi firmware, the ESP32 could now connect to the RPi AP when the network was open. That was new and progress. But it will would not connect when the AP was set to WPA.

A few minutes ago, I figured out how to set the AP to “WPA2” (it was configured as WPA) using Network Manager and I also got the ESP32 to connect to the AP.

So I think it might have been some combination of old/original firmware on this RPi 3B+ and having the AP set to WPA, instead of WPA2.

I’m going to pour myself a tall beer and take a break. And then get back to the ESP32 with OMG and see if things are working now.

Thank you and I apologize for the false alarm.

The OMG / LilyGo 433 Board now connects to my RPi AP using WPA2.

1 Like