Lilygo-rtl_433-fsk not sending home assistant config topics?

I’m still having problems with this gateway. It has been working for a while but again disappeared from Home Assistant.

I’m comparing the topics it creates with another lilygo that is using the default/ook build.

Ook build creates a topic like this:

But the Fsk build does not. I’ve tried rebooting, editing some settings and rebooting, but this topic is not being created.

Any idea?

did u check the console / display output on the device? maybe it is not detecting anything. in this case there might be less / no topics to create?

It’s not that. It was working fine, then stopped working.

I have just flashed it again, and now it’s published the config topic and visible in Home Assistant again. It’s all very strange and hard to reproduce.

Ps, as far as I know, the home assistant device discovery topic should be sent on reboot

Could you share what a message from your sensor looks like ?

Sure, here’s the latest one. (It’s all working again since the latest reflash)

{“model”:“Oil-SonicSmart”,“id”:144706964,“flags”:128,“maybetemp”:25,“temperature_C”:6.66667,“binding_countdown”:0,“depth_cm”:89,“protocol”:“Watchman Sonic / Apollo Ultrasonic / Beckett Rocket oil tank monitor”,“rssi”:-86,“duration”:140000}

Do you mean you have the auto-discovery that worked with this sensor now?

It took me quite some time to get both gateways (one flashed for OOK, the other FSK). After I got them working, they were good for many days. But, later, the FSK gateway (also the sensor) was no longer available in Home Assistant. I tracked it down to missing config messages like this:

{“stat_t”:“homeassistant/433FSKtoMQTT/SYStoMQTT”,“avty_t”:“homeassistant/433FSKtoMQTT/LWT”,“dev_cla”:“duration”,“unit_of_meas”:“s”,“name”:“SYS: Uptime”,“uniq_id”:“D4D4DA9EA110-uptime”,“val_tpl”:“{{ value_json.uptime }}”,“pl_avail”:“online”,“pl_not_avail”:“offline”,“state_class”:“measurement”,“device”:{“ids”:[“D4D4DA9EA110”],“name”:“433FSKtoMQTT”,“mdl”:“["LilyGo_SSD1306","WebUI","rtl_433"]”,“mf”:“OMG_community”,“cu”:“",“sw”:"v1.7.0”}}

Were no longer being sent. I tried reboot/power on-off but I could not get the gateway to be discovered again. When I re-flashed it, it came back.

Maybe because you deactivate auto-discovery?

If deactivated during the first 30 minutes, it will no longer activate automatically again unless you trigger it manualy.

Are you referring to auto discovery of the gateway? Or of devices, or both?

They could be the case, but I don’t remember. Is that documented, if so I missed it…

Auto-discovery is for both the gateway and the devices. We are not differentiating them.

I will add the 30 minutes to the documentation, does not seem to have it.

Thanks for the confirmation. I was aware of the 30 min thing but I understood that was for the devices, not the gateway itself so that would be good to clarify. Also good to mention that discovery on reboot won’t happen if it’s been manually turned off in the 30 min period.

1 Like