Lilygo V1.6.1 Lora Sender and openmqttgateway do not match correctly

hi, I am new to OpenMQTTGateway and very impressed so far.
i use two boards of Lilygo Model: T3 V1.6.1 20210104,
I programed two boards with this repository:

as sender and receiver and worked correctly.
then i download openmqttgatway directly from web by lilygo-rtl_433 to the receiver borad and confige, it connect to wifi and mqtt broker correctly but i can not receive my flasher messages from another board, while openmqttgatway receive more than 10 lora sensor from around!
it is a view of mqtt explorer:

I am totally confused.


You would need to use a LoRa environment, RTL_433 is for OOK demodulation, which is different than LoRa demodulation

thank you for your quick answer.
my board is 433/470 MHZ, it means i can’t use this for LoRa Gateway?
I upload two environment ( ttgo-lora32-v1-868 and ttgo-lora32-v1-915) but no work correctly and i cannot connect to wifi and configure.

There are no pre built binary for Lilygo LORA32 at 433mhz

The future release will add the capability to change the LORA frequency from the WebUI, you can test it below:

Thanks a lot, I uploaded ttgo lora32 v21 and OMG runed properly. I changed Frequency in WeBUI → LoRa config to 433 MHZ and saved then restarted the OMG.
I uploaded on another board LoRa Sender From this repository :

with set the board to LILYGO_T3_V1_6 and set LoRa Frequency to 433E6, but i did not recive signal in OMG, I try to use this example in OMG documents but it is missed:

I sincerely thank you for your patience.

I have a similar situation, needing to use my LiLiGo LORA32 T3_V1.6.1 board as the LORA gateway to MQTT. There is another alternative I just found. It involved building the project in VS Code PlatformIO, but it seems to work for me. The hint I needed was in the (Option 3) Upload your configurations section of the Build page. What I did was:

  1. Clone the Github repo
  2. Change the branch to v1.6.0 (Really important! Wasted a few hours on failing builds in the default “development” branch)
  3. Add my own liligo_lora_env.ini file to the top level directory
  4. In that file, I have:
default_envs = ttgo-lora32-v1-433

extends = env:ttgo-lora32-v1-868
build_flags =
    '-DZwebUI="WebUI"'  ; enable WebUI as a default for all ESP32 builds ( the module only enables for ESP32 based builds )

You may need to tweak the LORA radio parameters other than SPREADING_FACTOR to match your transmitter. That happened to be the only one I needed to change to get everything working.

One more thing…
I got a compile error from line 2002 of main.ino so I commented that line out. Nothing seems to to depend on that JSON element, so it did not impact anything negatively.

// SYSdata["env"] = ENV_NAME;


I also spend 3+ days to figure it out, I used also some sender github reps +gateway firmware was picked up based on this totorial:

with this board: LILYGO® TTGO LoRa32 V2.1_1.6 Version 433 - I see lot of neightbor sensors;

LILYGO® TTGO Meshtastic T-Beam V1.2 ESP32 LoRa Development Board 433MHz - with this I did not managed to get it work with firmware that is told to use in that YT video. ( [lilygo-rtl_433] lilygo-rtl_433 - ttgo-lora32-v21)
but with
ttgo-lora32-v1 - it boots up, in web UI I see LOA settings, sat to 433… but in mqtt explored no RTL_433toMQTT, seems it does not receive anything, either issue with board or wrong firmware. But it works with Meshtastic (messhaes goes in/out on primary chennel).

also, noob question, any chance to add Meshtastic (device as sensor) to see it in OMG? I have only two boards, not sure does my T Beam works, maybe board issue as it does not appead as sensor.

Hi I would just like to help the case along, also in my own interest :slight_smile: .

I use the same two boards of Lilygo Model: T3 V1.6.1 20210104, only the 868mhz edition. I programmed the two boards with the same repository as mohamad_saleh_Ebrahi and sending and receiving packages worked fine.

As suggested by 1technophile I tried ttgo-lora32-v1-868 (which seems to just be ttgo-lora32-v1 now) and it did not work on this board. Seems like the scripts are in constant development so:
Then tried ttgo-lora32-v21 which I could hook up to Wi-Fi and mqtt, so far so good.

Logging into the gateway and looking at the console it seems to receive the lora packages but there is still a fault:

E: LORA packet deserialization failed: InvalidInput, buffer capacity: 768
E: Empty JSON, not published

So will now be looking into that.