Limited number of Fineoffset sensors are visible

I got a lilygo 433 esp32 board with version 1.5.0 on it. It looks fine and shows some sensors. But if I run rtl_433 on the Ubuntu box next to it with a RTL2832U sdr-board connected, it shows way more sensors.
From the gw I see two sensors that shows up in the Fineoffset-WH5 and also in Fineoffset-WH2. And one more time in Fineoffset-TelldusProve. I get some sensors in the Interlogix-Security and Oregon-CM180i but from the sdr I got so many more. How is that? Is there any tuning to do or is the library rtl_433 different?

The library within OMG is a subset of rtl_433, as we needed to remove any device decoders that were too resource intensive for an ESP, and at the same the radio signal receivers are only working for signals with OOK modulation. Added to the mix, is that the receiver is not as sensitive as a rtl_sdr, and I found I get about 50% of the range.

That might explain it. But sorry to say, the device decoders that were removed looks like they affect the sensors I want to catch…

There is another release coming shortly which will update the device decoders and possibly include the sensor your looking for.


Try increasing the mqtt buffer size


@NorthernMan54 with the new FSK support, is it likely that the Cavius device decoder might get included for OMG ? I would love to be able to use this for a bunch of Cavius smoke alarms I have.

Or would I be better off just hooking up a RFM69 to a ESP32 ?


Apologies for jumping on the end of this thread, but it appears to be similar to my situation.

Firstly, I’m really new to all of this stuff, from Home Assistant to the mqtt, node red etc. The 433Mhz stuff though I have a vague level of experience with having played a little bit with an SDR a while ago.

Anyway, having watched Andreas Spiess’s YT video on 433 and the Lilygo ESP board, I purchased one and have followed the doco on the web site to flash it with the rtl433 firmware.

Below is a screen shot of the discovered devices. What I was hoping to get is the WH1080 Fine Offset weather station in my back yard. It’s yet to appear, even though the board has been running for about an hour or so.

Interestingly I have the old LCD reciever on the desk up against the wall and behind a monitor and it’s picking up the signal fine.

Is there any I’m missing or can try to see if I can pick up the weather station? I tried changing the receive frequency but I’m not sure how the topics work still…


With the FSK support I have no ability to test the FSK as I don’t have any real FSK devices, so I can’t say if it will work or not. I did the development with a simple FSK transmitter I created with a CC1101, so I can that it works with that setup, but with a real sensor I don’t know.

With the WH1080 Fine Offset is has two models, one with OOK and one with FSK. What version do you have? If your on the correct frequency, the OOK version should work.

Thx for the suggestion. Is that when compiling or sending as MQTT?

It’s when you initialize the mqtt client.

const char* mqtt_server = “”;
WiFiClient espClient;
PubSubClient mqtt_client(espClient)

mqtt_client.setServer(mqtt_server, 1883);
mqtt_client.subscribe(“OpenMQTT/Gateway_433/RTL_433toMQTT/Fineoffset-WHx080/#”, 0);

Do you see all(?) the Fineoffset messages in something like MQTT Explorer or with the mosquitto_sub command?

well, first, I use the precompiled version so with that one it’s not possible to increase the buffer size.
And for messages, I use MQTT Explorer and there I only see a few of the expected ones. Same with sub #.

Thanks for the reply.

Given that I was standing within a couple of meters of the weather station, I’d have to take a guess and suggest it’s FSK.

I tried Googling it to see if it’s actually stated what keying method it uses, but didn’t find anything helpful.

Is there a way to find out? I could try to find my RTL-SDR dongle. I’ll do some more googling.

Thanks again,


In that case I would have to guess the OpenMQTTGateway is either too far from the weather station or there are too many obstacles between the gateway and the weather station. [NorthernMan54] mentioned above that the receiver in the LoRa32 V2.1_1.6 “is not as sensitive as a rtl_sdr, and I found I get about 50% of the range.” I had the same problem with my LoRa32. There were four walls between the gateway and the WS. Moving the gateway so there is only a single window in the way fixed the issue.

Hi @NorthernMan54 ,

Just letting you know, I’ve just disovered/confirmed that the weather station doesn’t appear to be transmitting…

So I’ll need to check into that… so I suspect that’s been my issue all along.


Happy to report that with a battery change the station is now transmitting again and I can see it on the ESP32.

Apologies for the noise…

Hi @plaven I have a few questions. Which kind of WH1080 you are using the one with 868Mhz or 434Mhz? And what is the used modulation ASK or OOK. I’m having an WH1080 / 868Mhz and tried to receive the signal by means an ESP and connected RFM69 … but so far without success.
I need simply a gateway WH1080 → MQTT to get the data inside the Home assistant.