Missing SRFBtoMQTT

Just installed V1.6 on a hacked Sonoff RF Bridge;
I flashed the associated binary (rfbridge-direct-firmware.bin) via a standard flasher (Tasmotizer as for some reason PYflasher uploads but never works )
Everything works as expected, however I am missing the SRFBtoMQTT topic.

Is this an intended behavior and I have to use a custom binary or is there something else going on?
I’ve tried 2 different units with same result.

edit: also tried v1.5, no luck. Rolling back to v0.96 works.


Don’t know if you’re having the same problem as me. OMG v1.3.0 detected my 433 MHz door sensors but had a problems with OMG v1.5.1 and above. However my 433 MHz PIR sensor was detected by all versions.

As a quick test in platformio.ini for OMG v1.5.1 I changed
esp32_platform = espressif32@6.1.0
esp32_platform = espressif32@3.5.0
and the door sensor range problem seems to have gone away. The 433 MHz PIR sensors and Sonoff RM433 remotes also work but wasn’t having a problem with them before.

Maybe there’s a common root cause but the Sonoff RF Bridge runs on ESP82xx so I doubt the “esp32_platform” is the issue here; hopefully @1technophile can chime in =)

Just a quick follow up; can someone reproduce the issue? Thank you

I don’t have a sonoff rf bridge setup for the moment unfortunately

Ok got it…
thought the “rfbridge-direct” ready-to-go binary had SRFB enabled which doesn’t seem to be the case.
I compiled a new binary with

ZgatewayPilight “Pilight”
ZgatewaySRFB “SRFB”

which now works =)

I also enabled ZmqttDiscovery “HADiscovery” but couldn’t find documentation on it.
Is it supposed to automatically create devices in Home Assistant (like on the ESP32)?
if so, which parameters will trigger device creation?

For instance I have a RF temperature sensor broadcasting this JSON:

  "message": {
    "id": 4,
    "channel": 2,
    "battery": 0,
    "temperature": 24.9,
    "humidity": 52
  "protocol": "nexus",
  "length": "4",
  "value": "4",
  "repeats": 2,
  "status": 2

or a motion sensor


but no devices created in HA.

Can you point to some details/documentation on how ZmqttDiscovery “HADiscovery” works? Or is the feature unsupported on RFbridge and I manually create devices as per

If so I guess there’s no use enabling ZmqttDiscovery “HADiscovery” on the Sonoff RF Bridge, right?

Thank you!

Yes you have to create them manually.

AutoDiscovery works with the gateway itself, BT and RTL_433 for now

Thanks for confirming.
Will keep an eye on future releases but already started creating them manually;
Meanwhile, is there any potential issue with keeping “HADiscovery” enabled? IE; should I compile a new binary?
Thank you

No particular issue. More of an advantage as you can control the gateway directly from the devices panel without creating a YAML definition for it.

1 Like