Multiple and changed values for RF buttons

#1

Hi,

New user, so excuse my ignorance and thanks for the great software!

I have purchased these buttons:

I have installed V0.9 OMG on a esp8266.

I have wired one of these to D7 (didn’t work on the default pin, but found a post that said try d7):

I have soldered the antenna as supplied.

I have successfully connected to my MQTT broker and can see the GatewayRF in my homeassistant instance.

My issue is when I press one of my buttons I get multiple and different values. EG from my broker when I press the same button 3 times:

home/OpenMQTTGateway/433toMQTT {“value”:11141857,“protocol”:1,“length”:24,“delay”:274}
home/OpenMQTTGateway/433toMQTT {“value”:11240161,“protocol”:1,“length”:24,“delay”:273}
home/OpenMQTTGateway/433toMQTT {“value”:11141857,“protocol”:1,“length”:24,“delay”:273}
home/OpenMQTTGateway/433toMQTT {“value”:11240033,“protocol”:1,“length”:24,“delay”:274}
home/OpenMQTTGateway/433toMQTT {“value”:11043553,“protocol”:1,“length”:24,“delay”:274}

I’ll add a photo of my setup.

I have checked the voltage at the receiver and it is showing exactly 5v.

Many thanks for any help.

John

#2

I have got a little further!

Changed to PiLight and am now starting to see some consistency but the identical looking buttons are behaving slightly differently…

Button 1:

home/OpenMQTTGateway/PilighttoMQTT {“message”:"{“unitcode”:742785,“state”:“closed”}",“protocol”:“ev1527”,“length”:"",“repeats”:3,“status”:2}
home/OpenMQTTGateway/PilighttoMQTT {“message”:"{“unitcode”:611580,“state”:“closed”}",“protocol”:“kerui_D026”,“length”:"",“repeats”:4,“status”:2}
home/OpenMQTTGateway/PilighttoMQTT {“message”:"{“id”:789846,“all”:1,“state”:“off”}",“protocol”:“cleverwatts”,“length”:“789846”,“repeats”:4,“status”:2}

Button 2:
home/OpenMQTTGateway/PilighttoMQTT {“message”:"{“unitcode”:810773,“state”:“closed”}",“protocol”:“ev1527”,“length”:"",“repeats”:2,“status”:2}

Button 3:
home/OpenMQTTGateway/PilighttoMQTT {“message”:"{“unitcode”:815522,“state”:“closed”}",“protocol”:“ev1527”,“length”:"",“repeats”:2,“status”:2}

Sometimes each button needs a “long” press (2 seconds)?

Can I adjust some settings to avoid the need for a long press?

John