Nodemcu & WL101-341 transmit/receive only picks up high pulslength


#1

So i’ve got myself a few WL101-341 RF transmitters and receivers.
i’ve got these to work at a few times before, picking up signals from various remotes laying around with
a raspberry pi.

i’ve been troubleshooting and trying to get OMG up and running with these for a few days now.
i’m pretty sure i’ve got the wiring right, since i can receive some signals, and send some.

i’ve tried 3 different remotes for wall plugs, all 433mhz and no rolling codes, from different suppliers.

i get a signal from one of them:

2018-12-20 19:49:10[node: Debug] home/OpenMQTTGateway/433toMQTT/protocol : msg.payload : string[1]

“5”

2018-12-20 19:49:10[node: Debug] home/OpenMQTTGateway/433toMQTT/bits : msg.payload : string[2]

“16”

2018-12-20 19:49:10[node: Debug] home/OpenMQTTGateway/433toMQTT/length : msg.payload : string[3]

“806”

2018-12-20 19:49:10[node: Debug] home/OpenMQTTGateway/433toMQTT : msg.payload : string[4]

“2595”

but the other two won’t give any signals.

Trying to resend this code by MQTT won’t yield any response from the wall-plug: home/OpenMQTTGateway/commands/PLSL_805/433_5/RFBITS_16 2595
Through node-red -> homeassistant

Though sending a code i’ve got noted down from earlier for another plug / remote:
home/OpenMQTTGateway/commands/MQTTto433 2987620
works great, even though i can’t reveive it from the remote…

What am i missing here? why cant i receive all remote signals? why cant i send the signal i reveived?
Using V0.8 compiled in arduino IDE 1.8.8

Happy holidays!


#2

Hello Robin,

It could be a decoding issue with rcswitch, would it be possible to try v0.9beta from the master, we changed the rcswitch version to one with more protocols.

Happy holidays to you to!


#3

hmm, Updating seems to break the ability to both send and reveive signals…

With the same hardware setup but with 0.9 i get no respons in the mqtt, other than “online” and “0.9beta”…
havent checked the serial monitor yet though.


#4

Yep it could be interesting to have your serial monitor traces so as to see if it is due to v0.9beta or to a config issue.


#5

the serial monitor registers the callback back won’t give any info about it, as it did before.
it also creates a RF buffer when i’m clicking my remote but doesnt seem to sending it through mqtt

Setup OpenMQTTGateway end
MQTT connection…
Connected to broker
Subscription OK to the subjects
Hey I got a callback
Hey I got a callback
Creating RF buffer
Rcv. RF
LED MNG
isAduplicate?
Adv data RFtoMQTT


#6

Did you updated the libraries also with the version provided into OMG repo?
In particular pubsubclient?

Please note that to activate simplePublishing (like on previous version) you need to uncomment this line:


#7

Yeh, saw that post about the simplePublish, i’ve got both active when troubleshooting now.
Ok, so updating the libraries helped some. though now i get really weird results. now only some of the signals get through from the previously working remote… seems to be only the “off” buttons on the remote.
still no signal from the other remotes.
And now i cant send the code that previously worked.


#8

As we have introduced a new version of rcswitch this maybe the cause.

Could you try to go back to previous rcswitch version, the one included with V0.8 (and keep the other libraries and code as it is )?