Not able to send any RF data


#1

Hi guys,
first of all thank you for your great work. I am using the gateway in combination with Openhab and it works great!

Unfortunately I have a problem that I could not solve, although I tried different things and studied all the instructions on git.

I also checked the transmitter on a raspberry pi it it is working fine.

My board is a NodeMCU V3. Receiving a signal is no problem. My pin configuration in configRF.h is as follows:

#ifdef ESP8266
    #define RF_RECEIVER_PIN 4 // D3 on nodemcu
    #define RF_EMITTER_PIN 16 // RX on nodemcu if it doesn't work with 3, try with 4 (D2)

I also tried pin 3 (RX) but that didn´t work either.
I want to switch some plugs of different brands.If I press the button on the remote I receive the following code:

home/OpenMQTTGateway/433toMQTT
{"value":4543825,"protocol":1,"length":24,"delay":315}

I tried to send that one with the follwong command:
mosquitto_pub -t home/OpenMQTTGateway/MQTTto433 -m 4543825

but nothing happens.

This is only a received code I wanted to send but nothing happend:

home/OpenMQTTGateway/433toMQTT
{"value":5651376,"protocol":2,"length":24,"delay":724}

Is there anybody here who could give me a hint what I am doing wrong?
Thanks in advance!


#2

Hello,

Did you tried with Emitter on D2 = 4 and receiver on D3 = 0?


#3

Yes I have already tried this constellation but unfortuately then the receive command doesn´t work either.


#4

Are you using the beta? If so try version 0.8 - I ran into troubles with beta.


#5

Yes you are right, I just downloaded the repository and not the release version 🤦
I will give a try this afternoon and see if it’s works now.