Nut, miband and amazfit

hello, I have just rehinstalled on home assistant in TheengsGateway addons for the presence, I see that there are always well seen by the gateway, but they are unknown for the purpose and for the watches, we see the number of steps , presence is still not enabled. is possible of the activity?

For your Mi Bands and Amazfit GTR to see the steps and activity heart rate you will need to set both options to ON for them in the Zepp Life app


For presence detection in HA you need to set hasspresence to true, as described at

This is also available in the Gateway controller settings UI.

I don’t have this button

Sorry, my bad, the presence detection is currently only available in OpenMQTTGateway (running on an ESP32), as described in the link above.

With Theengs Gateway (Add-on) only the steps and activity heart rate are currently supported, but we’re looking into brining the presence detection with auto-away to Theengs bgateway in the future as well.

it’s a shame if you want I can test for it to work tell me which ones to do because I have several rpi.

we would be several used the addon

once the esp 32 flasher how do you fiat it
mosquitto_pub -t home/OpenMQTTGateway/commands/MQTTtoBT/config -m ‘{“hasspresence”:true}’

The two easiest options should be

• in the OpemMQTTGateway HA control setting

• in the Console part of the WebUI

Hello, once the gateway is installed, my bluetooth device goes back well, my how can’t I find them in home assistant, my say is it this watch?

I’m sorry, but I don’t fully understand what you mean.

You possibly have to turn on Auto Discovery in the gateway configuration UI again, as it automatically switches off after 30 minutes to avoid having unwanted devices auto-discovered.

Did you follow the instructions in the above first link?

Hello, here are the nuts that I get with an esp 32, how can I tell who they are because I can’t find their identifiers

I answer myself, it’s the last digit of the IDs