Github Boards Devices Community Docs Blog

OMG send correct signal but blinds not responding (315mhz)

I build an OMG with a wemos d1 mini and a 315mhz transmitter and receiver. I want to use it to add a custom made (Chinese) blind to my home automation. The remote has a 2-digit 7-segment display on which I can choose 0-99 (I think these are channels), and has an up/down/stop button.
What is strange is that if I pair the remote to channel 0 it also works on channel 1, but ok…
If I use channel 0 the only button that is received by OMG is the stop button, if I use channel 1 only up and down are received. Here’s an example.
N: Subject: /433toMQTT
N: Received json : {“value”:2686484673,“protocol”:2,“length”:32,“delay”:590}
N: no pub. dupl
N: Received json : {“value”:2686484673,“protocol”:2,“length”:32,“delay”:590}
The problem is that when I send this signal with the OMG the blinds don’t respond. I thought maybe I send the wrong info, so I build another transmitter and receiver and used tasmota on this, same thing the blinds don’t respond to this either. But I also used this one to check what was received.
What puzzles me is that when I use the remote, or the OMG, I see on the tasmota device it receives the exact same thing! The transmitter is very close to the blinds so it’s not a receiving issue (the tasmota is much further away and receives all fine).
I use #define ZgatewayRF “RF” //ESP8266, Arduino, ESP32, if I use RF2 or Pilight the OMG does not receive anything.
I really have no idea why it is not working, so hoping someone smarter than me can help me out.

Have you tried comparing the RF signal output from the remote versus OMG with a rtl-sdr ? If found that when I was comparing the signals between the 2, OMG may be slightly different and I needed to adjust the settings slightly for it to work consistently. To find the proper settings it took a bit of trial and error based on the signal analysis.

I use a workflow similar to this to analysis the signals SDR – My 433 MHz door bell – QUASSI

I think I have an rtf-sdr somewhere but I will have to search to for it. I looked at the signal analysis link and this is whole new territory for me. You said you had to adjust the setting slightly, what settings are those?

I had adjusted the delay and repeat option to get the signal to match what the remote was transmitting. It did take a bit of time, as I made an adjustment, compared the signals, then repeated. With my device what I found was that the signal was too long when compared to the actual remote and needed to reduce delay in order to get it to work. But without doing the signal analysis it would be just shooting in the dark, so for me that was the key in getting it to work.

I have found my rtf-sdr and was able to capture the signal, it seems the delay (that’s the same as pulse length right?) is off.
I am running all under windows, and am having trouble to get the rtl_sdr tool to work to analyse the signal. Is there another way to find the ‘delay’?

I think I got rtl_sdr now working, will test and look at the signal tomorrow as my son is sleeping and the remote controls the blinds in his room :wink: