OpenMQTTGateway (SRX882 STX882) 433mhz error

Hello community can someone please help me? I have flashed OpenMQTTGateway on an esp8266. As a module I have attached a 433mhz (stx882 & srx882) and via mqtt I get the error.

Socket error on client OpenMQTTGateway, disconnecting.
1560193438: New client connected from 192.168.1.xxx as OpenMQTTGateway (c1, k15, u’yoda12’).

I checked the registration data several times and it fits. But the module does not even find the door sensor (GS-WDS07). And about mqttfx. Wi-Fi signal. I have to install the OpenMQTTGateway on 2 esp once as. Binary and the other one ino file and your own mistake. finds no sensor at all.

Hello,

If you try to connect to your broker with a simple mosquitto_sub command did you succeed?

hello have tried everything the temperature was displayed wrong, the 433mhz did not work showed me only error messages, did not recognize the 433mhz sensors. After experimenting almost all night, I decided to try tasmota, which worked very well from the start. With tasmota, the esp8266 immediately recognized the door sensor and smoke detector.

There is several questions in your messages:

Could you explain from where your temperature is coming?

Did you uncommented ZgatewayRF?

Tasmota use the same base library has OMG ZgatewayRF (RCSwitch), there should not be a reason why OMG doesn’t recognise some sensors recognised by tasmota.
In addition more than 20 protocols have been added to OMG compared to base RCSwitch since this PR that you will not have with Tasmota.

I have attached a dht11. Yes, I commented out rf. No idea what was going on but with tasmota works perfectly.

Did you uncommented ZsensorDHT also ?