OpenMQTTGateway v1.0.0

An exciting release for OpenMQTTGateway, with 3 major changes:

  • @NorthernMan54 added the support of the HELTEC LORA 32 v2/v2.1 433Mhz with RTL_433 :signal_strength:. Isn’t it huge?:partying_face:
    No need to solder or check pins. Just upload heltec-rtl_433 from the web upload to the board, and you will benefit from the most powerful 433mhz library decoding, RTL_433 , we support Pulse Position Modulation (OOK_PPM) and Pulse Width Modulation (OOK_PWM) as a start (this is 80 decoders🙂).
    A great way to pick up weather stations, sensors, door bells… the list of compatible devices is huge. Feel free to share your feedback in the forum.
  • Added to the 433mhz, @DigiH did a huge work on the Bluetooth decoder, adding many new devices and improving the existing ones!
    The decoder now supports more than 55 devices!
    You can enjoy this changes with OpenMQTTGateway, but also with the TheengsGateway, the Theengs App will be updated soon.
    Note that Theengs Gateway can also work with OpenMQTTGateway as satellites/proxies. See our MQTTtoMQTT function implemented in June in OMG.
  • Thanks to @BadWolf42, we can now persist the BLE configuration to don’t rely only on the broker-retained values

And plenty of other changes thanks to the help of our contributors.

What’s Changed

New BLE devices and changes:

Devices Model Measurements
Amazfit Smart Watch/Band steps, activity heart rate (when activated in the Zepp Life settings)
ClearGrass CGG1 multi firmware support PVVX-ATC
Hydractiva Digital Amphiro/Oras sessions/time/litres/temperature/energy
April Brother ABTemp uuid/mfid/major/txpower @ 1 m/temperature/battery
April Brother N03 temperature/humidity/luminance/battery
ClearGrass Clock LYWSD02 temperature/humidity/battery
Oria/Brifit/SigmaWit/SensorPro TH Sensor temperature/humidity/battery
Qingping CGPR1 presence/luminance/battery
Qingping CGDN1 temperature/humidity/PM2.5/PM10/carbon dioxide
RDL52832 mfid/uuid/minor/major/txpower @ 1 m/temperature/humidity/acceleration
RBaron b-parasite moisture/temperature/humidity/luminance (v1.1.0+)/voltage
SmartDry Laundry Sensor temperature/humidity/shake/voltage/wake
Switchbot Motion Sensor movement/light level/sensing distance/led/scope tested/battery
Switchbot Contact Sensor contact/movement/scope tested/light level/battery
Switchbot Curtain motion state/position/light level/battery/calibration state
Thermobeacon WS02 temperature/humidity/voltage/timestamp/maximum temperature/maximum temperature timestamp/minimum temperature/minimum temperature timestamp
Thermobeacon WS08 temperature/humidity/voltage/timestamp/maximum temperature/maximum temperature timestamp/minimum temperature/minimum temperature timestamp
ThermoPro TP357 temperature/humidity
ThermoPro TP358 temperature/humidity
ThermoPro TP359 temperature/humidity
Oria/Brifit/SigmaWit/SensorPro TH Sensor temperature/humidity/battery
Otio/BeeWi Door & Window Sensor contact/battery

Features and fixes:


New Contributors

Full Changelog: v0.9.16…v1.0.0

Congratulations on v1.0.0 quite a milestone!

will have to look to update later.

1 Like

Ouh Sorry , i resolved by myself, just use the Web Upload methode, and the Display will show you the WiFi Setup Instructions .
Nice Job volks

Hello together again,
im struggeling to flash my Heltec V2 board.


im using the Instructions from the Help Page “3 - Upload”

but my V2 Board is doing nothing. just the Power LED is on. Serial Monitor is also death.
in the ESP Flasher Tool there is standing a 40MHz Clock, not 80MHz like in the Instruction (see Picture above)

Is the instruction still correct? Or do we have to update this also for the Heltec board?

Best Regards

Okay next “maintenance”
over Web Upload there is only OMG V 0.9.8 available? i get this info from Homeassistant

also Autodiscovery is not available

But OMG Logo is on display. So maybe its the 1.0 sw but in code info there is still 0.9.8


I just tried a web upload with the last version v1.1.0 and my Heltech RTL_433 and it worked out of the box:

Maybe try this again with this new version

so im at the end of my system knowledge with HA -.-
i did now test the receiving data from OMG, and it seems the payload reaches the broker
also i sent a Test Message from the MQTT Integration that is published by the Broker.

Now the MQTT Integration is not seeing the HeltecOMG board , but i have seen that the payload was detected by the Broker



the MQTT Integration will not discover the heltec board, i think i have read that if the connection was done once the Heltec board will not send a second " ready for discover " message or HA will not ask about it because the unique_id is known already

is it possible that i dont get the auto discovery because the heltec board was once wrong connected to the broker and now he will not change connection to the new 1.1.1 Version`? in the version description der is still the 0.9.8 listed annd that is the first Version i wanted to use last year, but that was not working for me

This sound for me like a HA issue

the last thing i did was to delete the MQTT Integration from the GUI, and renew the complete settings.
Now i even dont get the one device with 10 Entitys, there is nothing after delete the integration

but the broker has seen the commands from my rf Remote