Option1 Upload from web with lilygo-rtl_433, failed

Having followed the option 1 Upload from web with lilygo-rtl_433, on a T3_V1.6.1 433 Lilygo board, the process reached completion. However, the board never provided wifi.

Trying to flash again, the process loops forever in “preparing installation…”
Board is seen well in serial.

Any clues much welcome!

Hi @LEMD49,

unfortunately there seem to be some LilyGo T3_V1.6.1 433Mhz boards around which are causing issues.

I assume you have left the Erase Flash check box ticked when uploading lilygo-rtl_433 through the web upload?

If a fresh upload doesn’t seem possible - try holding and letting go of the RESET button on the LilyGo board when the upload initiates - you could also try the step suggested here to completely erase the flash and try the web upload again.

Some othersi n the team and myself have exactly the same board version and have not come across this unfortunate behaviour.

Let us know how you get on with the above.

1 Like

Many thanks for your quick response
And yes I did indeed select the erase option
I’ll try the other items suggested and let you know

@DigiH Here is the update. I tried again option 1, but this time using a Windows machine and Edge. Success with upload from web at first try. For info failed attempt was with macOS running BigSur 11.7.4 and Chrome.


Thanks for the update, especially with the initial issue being with macOS Big Sur and Chrome - something to remember if others might have similar problems.

1 Like

On a MacBookAirM1 that needed complete setup, after loading the drivers for the CH9102 serial port chip, the OpenMQTTGateway web installer worked perfectly fine. Hmmm, so I went back to the iMac15,1 running BigSur, downloaded the ch34xser_macos and installed. Voila! OMG Web install also worked perfectly on the configuration. So it was a group7 failure (“equipment not a fault”).


I had similar issue last week
‘web upload’ was failing all the time (yes I selected erase button too)
so I used the flash_download_tool.exe, works like a charm.

do an ‘erase’ and then flash the device with these parameters
Hope this helps for next time