Problems building ESP32 RF2

I am trying to build this on platformio with visual studio code.
I get this error:
C:/Users/Micke/Downloads/OpenMQTTGateway-0.9.2/OpenMQTTGateway-0.9.2/main/ZgatewayRF2.ino:40:34: fatal error: NewRemoteTransmitter.h: No such file or directory.

I am using the latest code from github and ahve this in my platformio.ini:

newremoteswitch = 1technophile/NewRemoteSwitch#8eb980e

I have no clue here. Any files that you want me to post?

Maybe try to clean your build env by using the garbage button of PIO.

If you go into

and into the folder corresponding to your environment do you find the NewRemoteSwitch library?

Dont mind what I wrote here…

Did a new test with everyting clead off.
Compiled RF just setting default_envs = esp32dev-rf in the ini file. That worked.

Commeted out #define ZgatewayRF2 “RF2” //ESP8266, Arduino, ESP32 in user_config.h

Got the error again. I must be missing some configuration step?

The library is not in any of the .pio/build/esp32dev-rf folders.

Problem solved, I downloaded it manually and put it in the lib folder.