Rain_rate_mm_h ignored

I have installed OMG ver 1.6.0 on a LILYGO LoRa32 V2.1_1.6 board.
Integration with Home Assistant is working, and I recieve values from my weather station.
Except one rain value.

Home Assistant auto discovery is ignoring value for
rain_rate_mm_h: 0

“model”: “Oregon-PCR800”,
“id”: 141,
“channel”: 0,
“battery_ok”: 1,
“rain_rate_mm_h”: 0,
“rain_mm”: 1712.29,
“protocol”: “Oregon Scientific Weather Sensor”,
“rssi”: -42,
“duration”: 518996


Any suggetions how to fix this?

I managed to solve it by doing “Option 4 - build from the web”
Changed the value “rain_mm_h” in “Config_RF.h” to “rain_rate_mm_h”, and compiled.

1 Like

Thanks for pointing this out.

I’ve submitted a fix and also corrected the device_classes, which you might also want to do with your custom build.

    {"rain_mm", "rain", "mm", "precipitation"},
    {"rain_rate_mm_h", "rain", "mm/h", "precipitation_intensity"},
    {"rain_in", "rain", "in", "precipitation"},
    {"rain_rate_in_h", "rain", "in/h", "precipitation_intensity"},