RF does not working


#1

I made the hardware as described.
I tried with Wemos D1 mini (esp8622) and with NodeMCU ESP-32S boards.
I tried to power the receiver and the transmitter with the board (it was only 4.6 V) and with external supply (about 7.8V).
I use OpenMQTTGateway v0.8.
The wifi and the mqtt work perfect.
But when I press any remote (I tried 3 different) it doesnát capture the signal.
I tried to change pins.
I didn’t measure circuit break.

Help me, please.


#2

Hello,

did you checked thetroubleshooting section


#3

Yes I did.

  • Verify your power supply voltage: I use an external power supply with 7.94V
  • Verify your wiring: I wired again
  • If you are only unable to receive RF on nodemcu: I tried D1, D2, D3 and D4 on Wemos D1 Mini

However the serial says: 17:55:20.353 -> Hey I got a callback, 17:55:20.353 -> Storing signal and in the home/OpenMQTTGateway/433toMQTT topic there is an RF code.
It’s a Broadlink TC-2 wall switch code but I don’t use it when I try to use OpenMQTT.


#4

Could you post your serial output when you press the buttons ?


#5

When I press the RF buttons no response. This Broadlink code comes when I restart the board.


#6

Are you sure the device is a compatible one ? Not all rf device are compatible


#7

Oooo. I thougt it just capture any RF code.
I tried with 2 noname cover remote and a Life garage door remote.
Am I right that it wont work with this remotes?


#8

Try with zgatewaypilight, it supports more protocols compared to zgatewayrf.


#9

I’ll try it.
Thanks for your help.