RF not working with wt32-eth SRX882

Hello,Thanks again for the project and the learning opportunities it gives!!

i have a new issue as i am trying to migrate from mega2560 to wt32-eth board.

IR is working correctly, RF receive doesn’t seem to respond.

I’ve tried swapping the pins, but the available pins are quite limited on this device.

I’ve tried 12, 14,15, 36 and 39 without any luck.

default_envs = 

platform = ${com.esp32_platform}
board = esp32-gateway
board_build.partitions = min_spiffs.csv
lib_deps =
 ; ${libraries.decoder}
build_flags =
  '-DZgatewayRF="RF"'  ;only IR for testing.
 ; '-DZgatewayIR="IR"'


extends = env:esp32-wt32-eth01-ble-eth
upload_protocol = espota
upload_port = ;OpenMQTTGateway_ESP32_WT32-ETH01.local
upload_flags =

Could it be related to the board definition in platformio? i can see that there is a board definition available:-

platform = espressif32@4.2.0
framework = arduino
board = wt32-eth01

but only from @4.2.0 I have no idea how this impacts the compilation of the project, is it worth trying?

Also tried a second SRX882 to be sure

Thanks for pointers.

I also noted the other post talking about same issue. I will test older versions, maybe something introduced in one of the more recent updates.

Tested with 0.9.13 and still nothing. Will look for a simple sketch to baseline the basics.

1 Like


You could start by testing the basic receiving example of RCSwitch with the different pins and see if any works with it

1 Like

Hello again. I’ve been slowly testing over the last week.

For the first 6 days i couldn’t get anything to work and was starting to think that the library no longer supported SRX882

in the last few days i managed to find a configuration that was working.

I created a sketch in platformio using the board definition mentioned in the first post. [env:wt32-eth01]
and after i got it to work i tested with all of the pins to see which would work.

I found that the following pins would work with the basic sketch you linked in the RCSwitch lib
: 32,33,39,17, and 35

I switched back to the openmqtt program/sketch and then retested all of the pins (Uses the “board = esp32-gateway”) as its definition, and in this case ONLY pin 17 will work with RF… and it crashes and reboots the device.
-(its listed at the txd pin so i don’t know if its because of this)
Any suggestions to move forward? ideally would have more pins to choose from
is it possible to implement the [env:wt32-eth01] as a board definition?
-requires platform = espressif32@4.2.0
anything else i can try?

I stopped the crashing with turning off the simple receiving and publishing. (Bug?)

Would still be handy to be able to choose different pins if you have any suggestions to help with that?