Github Boards Devices Community Docs Blog

RF sending problem (ESP01 V0.9.5 RF, FS1000A,)

Hi All,
I have an esp32-wroom-32 with OMG 0.9.5 installed and BLT and RF enabled. Bluetooth is working normally, RF reception is normal, but RF transmission has no response, and there is no error message. I just configured the BT and RF configuration in User_config.h is enabled, and nothing else is modified.
Later, I tried to install OMG 0.9.5 on esp01, only RF was enabled. The same is only received, no transmission, and no response and error. But when I installed OMG 0.9.3rc on this esp01, the OMG RF transceiver was normal. And I found that if OMG 0.9.3 is installed, it can be received. After transmission, a message, “Hey I got a callback”, will be received in the serial port monitor, but there is no other response and the transmission is not successful.
Is the system from OMG 0.9.3, what settings do I need to do? Or what I missed
Is there anybody here who could give me a hint what I am doing wrong?
Thanks in advance!

1 Like

Hi there I have the same. Problem with nodemcu I tried 3 different rf sender that all work with tasmota software no luck.

Hi,

Could you post a photo of your setup with v0.9.5, your user_config.h without credentials, an extract of the serial monitor when sending a command and the MQTTcommand you are using to send RF?

Thank you very much for your help

Here are some of my configurations:

  1. Development board setting
    Esp32 development board WiFi + Bluetooth Internet of things smart home esp-wroom-32 esp-32
    Receive: d27, transmit: D12

  2. Arduino board setting:

  3. Only user_config.h is modified in OMG:

  4. Contents of serial port monitor:

09:47:42.586 -> ************* WELCOME TO OpenMQTTGateway **************
09:47:42.680 -> {“mqtt_server”:“192.168.3.234”,“mqtt_port”:“1883”,“mqtt_user”:“hachina”,“mqtt_pass”:“y123456”,“mqtt_topic”:“home/”,“gateway_name”:“OpenMQTTGateway”}*WM: [3] allocating params bytes: 20
09:47:42.727 -> *WM: [2] Added Parameter: server
09:47:42.727 -> *WM: [2] Added Parameter: port
09:47:42.727 -> *WM: [2] Added Parameter: user
09:47:42.727 -> *WM: [2] Added Parameter: pass
09:47:42.727 -> *WM: [2] Added Parameter: name
09:47:42.727 -> *WM: [3] Updated _max_params: 10
09:47:42.727 -> *WM: [3] re-allocating params bytes: 40
09:47:42.727 -> *WM: [2] Added Parameter: topic
09:47:42.727 -> N: Attempting Wifi connection with saved AP: 0
09:47:43.240 -> {“mqtt_server”:“192.168.3.234”,“mqtt_port”:“1883”,“mqtt_user”:“hachina”,“mqtt_pass”:“y123456”,“mqtt_topic”:“home/”,“gateway_name”:“OpenMQTTGateway”}N: RF_EMITTER_GPIO: 12
09:47:44.737 -> N: RF_RECEIVER_GPIO: 27
09:47:44.737 -> N: BLE scans interval: 55555
09:47:44.737 -> N: BLE scans number before connect: 10
09:47:44.737 -> N: Publishing only BLE sensors: false
09:47:44.737 -> N: minrssi: 100
09:47:44.783 -> N: Low Power Mode: 0
09:47:44.783 -> N: Setup OpenMQTTGateway end
09:47:44.783 -> W: MQTT connection…
09:47:45.063 -> N: Connected to broker
09:47:45.063 -> N: Subject: /SYStoMQTT
09:47:45.063 -> N: Received json : {“uptime”:2,“version”:“version_tag”,“freemem”:158600,“rssi”:-68,“SSID”:“yaoyuan”,“ip”:“192.168.3.158”,“mac”:“F0:08:D1:C4:E2:A4”,“wifiprt”:0,“lowpowermode”:0,“interval”:55555,“scanbcnct”:10,“modules”:“RFBT”}
09:47:45.764 -> N: Scan begin
09:47:45.950 -> N: Device detected: 55:D8:EE:75:C2:01
09:47:45.997 -> N: Subject: /BTtoMQTT/55D8EE75C201
09:47:45.997 -> N: Received json : {“id”:“55:D8:EE:75:C2:01”,“rssi”:-50,“distance”:0.191064}
09:47:46.416 -> N: Device detected: 47:86:DC:29:0B:AF
09:47:46.463 -> N: Subject: /BTtoMQTT/4786DC290BAF
09:47:46.463 -> N: Received json : {“id”:“47:86:DC:29:0B:AF”,“rssi”:-87,“txpower”:12,“distance”:18.07764}
09:47:46.741 -> N: Device detected: A4:C1:38:21:4F:73
09:47:46.741 -> N: Subject: /BTtoMQTT/A4C138214F73
09:47:46.741 -> N: Received json : {“id”:“A4:C1:38:21:4F:73”,“name”:“ATC_214F73”,“rssi”:-66,“distance”:2.246586,“model”:“LYWSD03MMC_ATC”,“tempc”:18.7,“tempf”:65.66,“hum”:21,“batt”:74,“volt”:2.881}
09:47:48.657 -> N: Device detected: A4:C1:38:1F:84:FD
09:47:48.657 -> N: Subject: /BTtoMQTT/A4C1381F84FD
09:47:48.705 -> N: Received json : {“id”:“A4:C1:38:1F:84:FD”,“name”:“ATC_1F84FD”,“rssi”:-46,“distance”:0.082996,“model”:“LYWSD03MMC_ATC”,“tempc”:15.1,“tempf”:59.18,“hum”:24,“batt”:59,“volt”:2.751}
09:47:49.498 -> N: Device detected: FF:FF:44:05:51:3A
09:47:49.498 -> N: Subject: /BTtoMQTT/FFFF4405513A
09:47:49.498 -> N: Received json : {“id”:“FF:FF:44:05:51:3A”,“name”:"iTAG ",“rssi”:-59,“txpower”:0,“distance”:1.01076}
09:47:55.935 -> N: Found 5 devices, scan number 1 end deinit controller
09:47:55.935 -> N: BLE Connect begin
09:47:56.120 -> N: BLE Connect end

  1. Commands sent by mqtt Explorer
    Press the external RF button to receive the message:
    MQTT explorer:

    serial port monitor:

Send message in mqtt Explorer: home/OpenMQTTGateway/MQTTto433_1

The serial monitor has no messages

Send message in mqtt Explorer: home/OpenMQTTGateway/MQTTto433_1

The issue could be here.

Try to do it as per the docs below :

Topic :
home/OpenMQTTGateway/commands/MQTTto433

Payload :
{"value":5334345}

This is a mistake I just made. According to the home / openmqttgateway / commands / mqttto433, or home / openmqttgateway / commands / mqttto433_ 1. There is still no response

Are you publishing the payload as I mentioned ?

It should be. My mqtt broker is installed under docker. I do this all the time on mqtt explorer.

In addition, the same transceiver module and the same mqtt instruction are tested on esp01. OMG v0.9.3rc can receive and send, while v0.9.5 can only receive but not transmit

This is the topic, not the payload.

Here is how you should format your payload :
{"value":5334345} and publish it.

On v0.9.5 the simple payloads are not accepted per default. You need to publish a json payload as the one just above.

It’s ok now. This problem has been bothering me for a long time. Thank you very much

Glad to hear you got it working !
When you were doing your tests, were you referring on a particular outdated tutorial or video ?

Oh, no, I’ve been using OMG since v0.9.2. It’s just that as I continue to expand the range of rooms I use, I constantly add new gateways. Every time I add OMG, I try to use the latest version. Later, it was found that when it came to v0.9.3, it could not be sent any more, so it stopped at v0.9.3rc. So I still use the first tutorial. This time, I want to use the Bluetooth of esp32, which requires v0.9.5, so the problem is exposed

Can you give a configuration example in home assistant. I failed to configure according to the tutorial

switch:

  • platform: mqtt
    name: “light”
    state_topic: “home/OpenMQTTGateway/commands/MQTTto433”
    command_topic: "home/OpenMQTTGateway/commands/MQTTto433_1
    payload_on: 865378
    qos: “0”
    retain: true

I tried to change it. Now it’s OK. You may need to modify the tutorial

switch:

  • platform: mqtt
    name: “light”
    state_topic: “home/OpenMQTTGateway/commands/MQTTto433”
    command_topic: "home/OpenMQTTGateway/commands/MQTTto433_1
    payload_on: ‘{“value”:865378}’
    qos: “0”
    retain: true
1 Like

Thanks for pointing that.
The example is already corrected, but as the doc is not yet published you can’t see it :frowning: :

Will be ok for V0.9.6

I have almost the same problem i can receive but i can´t send! on serial monitor is ok but i have a gaterway with tasmota and cant see messages from 433mhz or the devices it sellfs

image

My question is the format of the message sent. If I use Arduino ide to flash, the format must be {“value”: 12345} to launch successfully. If I use the plantformio IDE, the format can be 12345, or {“value”: 12345}

Please open a different thread with more details as this seems to be a different issue, version used, MQTT command, configuration…