Send Raw data from MQTT to 433?

I have an esp32 with a cc1101 433mhz module, I want to be able to send some raw data which I got off of reddit in which the person was using tasamota and portisch to push an MQTT message from home assistant to their device. I have tried to use Pilight and “RF” library but every MQTT message I send gives an error of unable to parse data.

Are there any resources available to “convert” the raw data format for tasamota into another library supported by OMG?

I am not sure what other info I can provide but if anyone can point me in the direction I would greatly appreciate that.



P.S. please excuse the formatting and spelling mistake, I am writing this from mobile.

Not really, I would better advise to record the signal with OMG to reproduce it with the same firmware and configuration.

Thank you. I flashed with pilight off of the pre-compiled packages from the OMG website and I cannot seem to see any data. I followed the “use” section to subcribe to all mqtt topics but I really don’t see anything useful.

The closest I can see is this message: N: Send on /RFtoMQTT msg {“active”:1,“frequency”:433.92}

However I cannot tell what this is as this shows up even when I don’t press my remote button, so I am thinking if this is a device it is likely some other 433 device it is picking up (weather sensor perhaps).

Any pointers to try and dive deeper?

To note my remote is a 1 channel 433.92 - based on research it should be on channel 1.

thanks for any insight you can provide!


Hi @markuslt,

could it be that your remote is not using a protocol which is decodable by the Pilight library, but one of the other RF libraries?

Alternatively you might want to try the RF(RCSwitch) or RF2(KaKu) libraries, as the


message you are seeing is only confirming that you are using the Pilight library with 433.92 MHz.

Try the esp32dev-rf binary, or possibly the esp32dev-multi_receiver with which you can switch between different protocols.

Thanks, I’ve tried with all and I can’t seem to get any data at all.

The remote FCC ID shows the device using 433.904, I set the channel to that in the RF config, is that correct?

Any other pointers? I’m going to keep digging and trying to get this going.

Thanks again!

I’m afraid that if you have tried through all RF protocols, RF, RF2 and Pilight, and couldn’t pick up anything this currently doesn’t seem possible with that specific remote :frowning:

I take it you were pretty close with the remote to the ESP32/CC1101,

Let us know if you find anything further. All the best with it!