Sending to 433 RF 4 channel Relay

#1

Hi, in a previous post on compatible devices, 433 RF 4 CH relays, I reported back that the Sonoff RF Bridge can receive the remote button presses from the eBay nonamebrand.

Here is an example of what I receive on mqtt on button A (You would see that no Protocol is reported):

home/OpenMQTTGateway/SRFBtoMQTT
Button A: 
{"raw":"2224013603AC4BC928","value":4966696,"delay":8740,"val_Thigh":310,"val_Tlow":940}

The remote works very well to its own 4 channel relay. Not to send same signal via mqtt to Sonoff bridge, onwards to the 4 Channel relay.

I tried SENDING the following, with and without the delay json pair, neither works:

home/OpenMQTTGateway/MQTTtoSRFB
{"value":4966689,"delay":8720}

Any ideas? Is it a Protocol issue? If I do receive the message, without a Protocol in the message, which protocol would it be?

#2

Your value seems to don’t correspond to Button A:
4966689<>4966696

Try sending this maybe:
'{"value":4966696,"delay":8740,"val_Thigh":310,"val_Tlow":940}'

#3

Nope, the remote has 4 buttons, I have given the values of buttons A and D, that is the only differences between the buttons. Also tried that, any other ideas?

#5

I also tried the Raw mode in Node-RED:

msg.topic = ‘home/OpenMQTTGateway/commands/MQTTtoSRFB/Raw’;
msg.payload = {“raw”:“2224013603AC4BC921”};

Into an mqtt Send node.

But I assume - as per your documentation - with the Sonoff RF Bridge we cannot trust that.
NOTE: currently the device doesn't receive correct values from Switches remote control

#6

Hurray !

Got it working.

{"value":4966696,"delay":8740,"val_Thigh":930,"val_Tlow":330}
1 Like