Github Boards Devices Community Docs Blog

Some sort of silly error, but I can not find it

Hello!

So, I gave away my OpenMQTT gateway to a friend, and thought I would just build a new one. But, I can not get 433 receive to work. I realize I must be missing something silly.

I have a generic ESP32 module with the following pinout. https://cdn.shopify.com/s/files/1/1509/1638/files/ESP-32_NodeMCU_Developmentboard_Pinout.pdf?v=1609851295
I have my STX-882 / SRX-882. My SRX has a pinout that seem to differ from the reference listed here RF gateway (433mhz/315mhz) | OpenMQTTGateway v0.9.5

The pinout of my module is GND, DATA, CS, VCC

I am using the ESP32-dev libraries.

So, the data pin of the SRX is connected to G16 of the ESP32 (And the data pin of the STX is G4).

Nothing I’ve tried seem make me be able to receive data. I’ve tried the “CS” pin in case my module would have happened to been mislabelled. But no joy.

My oscilloscope shows a nice enough pulse train on the data pin when i press a button on my remote,

But hey, BTLE works nice enough.

What the heckish might I have missed here?

Eddendum: Hm, interesting. If I look at the signal with oscilloscope I see a nice signal.

But when i have connected the data to my ESP pin, the signal seem to be constantly pulled low. Now I am confused big time.

************* WELCOME TO OpenMQTTGateway **************
{“mqtt_server”:“172.25.74.30”,“mqtt_port”:“1883”,“mqtt_user”:“redacted”,“mqtt_pass”:“redacted”,“mqtt_topic”:“openmqttgateway/”,“gateway_name”:“OpenMQTTGateway”}*WM: [3] allocating params bytes: 20
*WM: [2] Added Parameter: server
*WM: [2] Added Parameter: port
*WM: [2] Added Parameter: user
*WM: [2] Added Parameter: pass
*WM: [2] Added Parameter: name
*WM: [3] Updated _max_params: 10
*WM: [3] re-allocating params bytes: 40
*WM: [2] Added Parameter: topic
N: Attempting Wifi connection with saved AP: 0
{“mqtt_server”:“172.25.74.30”,“mqtt_port”:“1883”,“mqtt_user”:“OZW”,“mqtt_pass”:“OZW”,“mqtt_topic”:“openmqttgateway/”,“gateway_name”:“OpenMQTTGateway”}N: RF_EMITTER_GPIO: 16
N: RF_RECEIVER_GPIO: 4
N: BLE scans interval: 55555
N: BLE scans number before connect: 10
N: Publishing only BLE sensors: false
N: minrssi: 100
N: Low Power Mode: 0
N: Setup OpenMQTTGateway end
W: MQTT connection…
N: Connected to broker
N: Subject: /SYStoMQTT

Hello,

Did you tried with the GPIO indicated in the doc for RX(27/26) ?

Hello!

Yeah, that as well, according to the pinout, that should be GPIO3, so I entered

define RF_RECEIVER_GPIO 3 // D27 on DOIT ESP32

The signal just “dies” as soon as I hook it up. Wierd.

My old gateway was build around a Huzzah, and it “just worked”. :-/

Just try with 27 and not 3

That seem to give a constantly high when measuring on the pin with my scope. Disconnecting data pin again gives the expected pulse train.