Sonoff RF Bridge not receiving/pushing RF signals

Hi,
I*m completely new to the mqtt/RF stuff. I am trying to use the RF Bridge to receive signals from motion/door sensor and switch lights.
I flashed the Sonoff RF bridge with omg 0.91 (build it in the Arduino IDE, flashed with ESP Easy). I configure omg on the bridge and it is in my wifi network. I have a mosquitto server running on a raspberry pi. If I listen for mqtt messages with “sudo mosquitto_sub -t +/# -v”, I only get
home/OpenMQTTGateway/LWT offline
home/OpenMQTTGateway/version 0.9.1

But when I activate a sensor (door sensor or motion sensor), I get no mqtt message. On the RF bridge blinks a red led, but that’s all. Am I missing something? Do I have to pair the RF sensors with the bridge or something like that?

Thanks
Bernd

Hello,

If the LWT is offline it is not a good a point. It should be online first before you try with sensors.
Are you sure the gateway is connected to your wifi and your broker ?

Hi,

thanks for confirming my doubt, the “offline” message doesn’t seemhttp://drzzs.com/sonoff-rf-bridge/right to me. But the gateway is connected to my wifi (visible in my router) and since I get that message, I would assume that the connection to the broker works too.
What I did now was to take the bin from http://drzzs.com/sonoff-rf-bridge/. Its quite an old version (from last year), but now I get the following:
home/OpenMQTTGateway/LWT Online
home/OpenMQTTGateway/version 0.7

Also, I’m receiving mqtt messages from the rf devices.

So I think I made an error when compiling the .bin with Arduino IDE. All I did there was to comment all addons and modules except ZgatewaySRFB. Do I have to do more than that?

Thanks
Bernd

Try to get the signals using MQTT.fx Software
https://mqttfx.jensd.de/

You must have a MQTT broker configured to this method works. I’m using Raspberry Pi with Openhab.
On the software, you connect to the MQTT Broker IP (in my case is the Raspberry Pi IP) and then subscribe on MQTT.fx to the follow topic: home/OpenMQTTGateway/SRFBtoMQTT

You should be able to see the inputs from the sensors this way.

Nope, should be OK with that, what happens if you take the last binary files from there:
https://github.com/1technophile/OpenMQTTGateway/releases

I tried to flash ESP8266_OpenMQTTGateway_V091_RF.ino.bin (and to be safe the other bins too), but then the bridge doesn’t appear with its own WIFI network (and not in my wifi network either). Or do I have to supply the WIFI information with the ESP Easy Flasher?

Try to compile the code using Arduino IDE. Then you can edit the user config file and add your WIFI info.

If I sum up V0.7 is working and V091 not with the same flashing method (from a binary file)?

Yes exactly. V07 is accessable after flashing with its own wifi network, V091 doesn’t appear in any Wifi network.
I will experiment a bit with compiling the source code with Arduino IDE.

I will release v0.9.2 soon and I will provide different combination of binaires so that you can try the last version.

Well, don’t ask me why, but after playing a bit with the Arduino IDE, setting the WIFI/mqtt data in the user_config.h, it finally works! :slight_smile: I also did the upload with Arduino IDE instead of ESP Easy.
Just one last question concerning the OTA update, do I have to do anything to activate it? I don*t see the RF Bridge in the Arduino IDE as a Port.

It should work otb on the gateway side. For the ide there is some installation to do. If you google it you should find.

Great !