Support / ESP 8266 / SRX882 / Reboot loop after command push

Hello all

Posting as I don’t have much in the way of hair left to pull out.

NodeMCU 8266 board with SRX882. I’ve pushed binaries from the webpage or via direct BIN transfer. I’ve also compiled it myself and pushed through the arduino IDE . Same results with RF, RF2, or the Weather builds.

I have tried multiple ESP boards as well from different manufacturers. Same result.

Wifi connects fine. MQTT broker connect fine and I get 3 topics and its online.

The second I send the command to activate, it sets this device into a reboot loop. This occurs WITH or WITHOUT the RX/TX connected.

My only next step is to change the pin on the sketch… Unfortunately, I can’t locate where that is. Anyone locate the RX/TX pin on the sketch I can change OR give some more input on why this is occurring for me?

ets Jan 8 2013,rst cause:2, boot mode:(3,7)

load 0x4010f000, len 3460, room 16
tail 4
chksum 0xcc
load 0x3fff20b8, len 40, room 4
tail 4
chksum 0xc9
csum 0xc9
N: ⸮{
“mqtt_server”: “”,
“mqtt_port”: “1883”,
“mqtt_user”: “your_username”,
“mqtt_pass”: “your_password”,
“mqtt_topic”: “home/”,
“gateway_name”: “OpenMQTTGateway”,
“mqtt_broker_secure”: false,
“mqtt_broker_cert”: “”,
“mqtt_ss_index”: 0,
“ota_server_cert”: “”
}*wm:[2] Added Parameter: server
*wm:[2] Added Parameter: port
*wm:[2] Added Parameter: user
*wm:[2] Added Parameter: pass
*wm:[2] Added Parameter: secure
*wm:[2] Added Parameter: cert
*wm:[2] Added Parameter: name
*wm:[2] Added Parameter: topic
N: Attempting Wifi connection with saved AP: 0
N: Switching to RF Receiver
N: OpenMQTTGateway modules: [“RF”]
N: ************** Setup OpenMQTTGateway end **************
W: MQTT connection…
N: Connected to broker
N: Send on /SYStoMQTT msg {“uptime”:3,“version”:“v0.9.11”,“freemem”:33152,“mqttport”:“1883”,“mqttsecure”:false,“rssi”:-57,“SSID”:“SUNSHINE”,“ip”:“”,“mac”:“60:01:94:0B:97:0E”,“actRec”:2,“modules”:[“RF”]}

--------------- CUT HERE FOR EXCEPTION DECODER ---------------

Exception (28):
epc1=0x40203a32 epc2=0x00000000 epc3=0x00000000 excvaddr=0x00000000 depc=0x00000000


ctx: cont
sp: 3ffff9b0 end: 3fffffc0 offset: 0190
3ffffb40: 3ffe91e7 00000000 3ffffb80 40203a32
3ffffb50: 3ffffbb0 40067bc4 3ffffb80 3fff24a4
3ffffb60: 3fff32ef 40067bc4 3ffffb80 4020403e
3ffffb70: 00000000 00000000 3ffffed4 402040c1
3ffffb80: 3ffffe68 3a22227b 6c6c756e 0000222c
3ffffb90: 402031ce 00000005 00000000 3ffffe68
3ffffba0: 402199b0 0000000a 0000000a 3ffffe68
3ffffbb0: 00000000 3ffffc58 00000001 402031ce
3ffffbc0: 00000005 00000000 3ffffe68 402199b0
3ffffbd0: 00000000 3ffffe68 0000000a 3ffffc58
3ffffbe0: 00000001 402031ce 00000005 00000000
3ffffbf0: 3ffffe68 402199b0 00000000 3ffffe68
3ffffc00: 0000000a 3ffffc58 00000001 402031ce
3ffffc10: 00000005 00000000 3ffffe68 402199b0
3ffffc20: 00000000 3ffe9107 3ffffe68 402199e9
3ffffc30: 00000000 00000000 3ffffe40 40208268
3ffffc40: 3ffffc68 3ffffc68 3ffffe68 3ffffe68
3ffffc50: 00000000 3fff1c8c 3fff24a4 00000000
3ffffc60: 3fff2c04 3fff0480 3fff00e8 4022c155
3ffffc70: 00000355 00000355 3ffe8844 40100e17
3ffffc80: 3ffe8631 0000001e 3ffffcc0 3fff00d8
3ffffc90: 3ffffd20 00000020 3fff2cf4 40100ff6
3ffffca0: 3ffffd20 3ffe9272 3ffffcfc 402197f1
3ffffcb0: 00000002 00000000 00000020 4010058c
3ffffcc0: 40102af9 001e001f 00000002 401026c8
3ffffcd0: 3ffea7f2 40105947 3ffedf88 40100e17
3ffffce0: 00000001 40104b22 3ffee9b8 3fff00d8
3ffffcf0: 40104f93 00000020 3fff24a4 40100ff6
3ffffd00: 00be00bf 3ffffd20 3fffff48 402197f1
3ffffd10: 40104a5b 00000026 00000002 00040000
3ffffd20: 00002200 3ffffd77 3ffffe88 3fffff48
3ffffd30: 40103924 00080000 3fffff38 3ffffe98
3ffffd40: 3ffffd20 00000000 33383831 4e555300
3ffffd50: 4e494853 2c9f0300 4000050c 3fffc278
3ffffd60: 4010360c 3fffc200 00000022 42303a34
3ffffd70: 4000dd31 00000030 00000010 ffffffff
3ffffd80: 4000066d 8d6607e0 001114a9 00000039
3ffffd90: 00004bc6 8d6607e0 00000061 00000430
3ffffda0: 00003593 3fffc6fc 766a07e0 0039b482
3ffffdb0: 4bc6a7f0 00000036 3fffff58 00000030
3ffffdc0: 402198c9 00000000 00000006 00000000
3ffffdd0: 0016001f 00000000 3ffffe50 3fff0480
3ffffde0: 3fff1c8c 00000020 3fffff30 402198c9
3ffffdf0: 00000000 00000000 002b002f 00000000
3ffffe00: 3ffffe50 3fff0480 3fff1c8c 00000020
3ffffe10: 3fffff30 402198c9 00000000 00000000
3ffffe20: 0015001f 00000000 3ffffe50 3fff0480
3ffffe30: 3fff1c8c 00000020 3fffff30 402198c9
3ffffe40: 00000555 00000555 3ffe8844 40100e17
3ffffe50: 00000000 0014001f 00000000 00000001
3ffffe60: 3fff3cf4 00000020 00000000 3fff24a4
3ffffe70: 00000000 3fff24ac 9be70022 3ffffc40
3ffffe80: 00000000 4bc6a7f0 05a1cac0 001114f6
3ffffe90: 00000000 00000000 4bc6a7f0 00000000
3ffffea0: 00000ec5 3fff3d44 3fff17fc 4020b3b8
3ffffeb0: 00000ec6 3fff247c 00000026 0000000b
3ffffec0: 00000000 00000000 00000000 00000000
3ffffed0: 00000000 3ffffc58 3ffffc40 40208444
3ffffee0: 00000036 3fffff00 00000003 3fff3316
3ffffef0: 00000001 0000000e 00000020 3fff3316
3fffff00: 3fff24a4 3fff24b2 3fff32ef 4020834e
3fffff10: 00000026 00000035 00000037 00000001
3fffff20: 00000001 00000ec5 3fff00e8 4022bc9c
3fffff30: 00000001 00000ec5 3fff00e8 402089f1
3fffff40: 0000000e 3fff3316 3fff32ef 00000000
3fffff50: 3fffdad0 3fff1184 3fff0601 402268b0
3fffff60: 00000003 00000026 00000038 00000004
3fffff70: 3fff1384 3fff00e8 00000ec5 00000000
3fffff80: 3fff0178 3fff00e8 00000ec5 40206470
3fffff90: 3fffdad0 00000000 3fff08b0 3fff08c4
3fffffa0: 3fffdad0 00000000 3fff08b0 4021adac
3fffffb0: feefeffe feefeffe 3ffe8840 40101465

--------------- CUT HERE FOR EXCEPTION DECODER ---------------

Found the pin settings. Changed GPIO 0 to GPIO 5. Same results…

Frustrating… I’m sure this is something I’m doing but for the life of me I can’t find it.


Could you post your mqtt topic/command please?

home/OpenMQTTGateway/commands/MQTTto433 “active”:true

I believe that is the command to activate the device based on my reading. Again, if thats incorrect, please let me know.

I have also tried the MQTTtoRF2 accordingly. Same results.

I had the ESP running clean overnight without pushing a command, I just pushed the MQTTto433 command and it now is in the reboot loop again.

Do you add {} when you publish

Well… I knew it was something I was doing. Thats clearly labeled in the instructions.

Not sure why a malformed command would cause the reboot loop – but it seems to be working now.


1 Like