Turning off auto discovery in Home Assistant

Hi all. I’ve been running OpenMQTT Gateway on a lilygo-rtl_433 board for a long while now. I recently updated to current. I would like to turn off auto discovery for the gateway as I am picking up lots of RF sensors of my neighbors and it is blowing up my entities. I noticed these options in the HA device:

I tried turning both of those switches off but the top one turns itself right back on. Can someone tell me if I need to get both of these to turn off?

Lastly, will changing these switches to off cause the devices that are already recognized to not be recognized any longer? I do not have a problem with configuring these separately in my HA mqtt yaml config but would certainly prefer not to have to do that if it’s possible to just prevent future devices from being recognized automatically.

Any help is most appreciated! Thanks!


One of the switches is no longer connected to the gateway, which is why it returns to its initial state. You can remove it by deleting the associated payload in your MQTT broker (with a client like MQTT Explorer). It should be removed by v1.7.0. I am not sure why this is not the case with your setup.

The topic to remove is
you should keep:

If not turned OFF manually, the switch turns OFF automatically after 30 minutes upon each restart.

If you turn disc OFF while ON, it will be saved to the ESP memory and will not automatically turn back ON.

See it has a pairing mode, that stops after a certain time unless you switch it OFF.

Thank you for taking the time to explain this. It is exactly what I needed. Much appreciated.