Unable to connect to wifi with ESP32 WROOM-32

I’m trying out OpenMQTTGateway for the first time, and I have an ESP32 Devkit-C WROOM-32 board with a CH340 chip which I flashed the esp32dev-ble firmware onto, but I’m not sure if this is the right one since it seems to be unable to connect to wifi?

After flashing the ESP does boot up and I can connect to the OMG AP and try to connect to my LAN wifi, but the board fails to connect. This is definitely a problem with the board/firmware (or configuration) itself as I already have other ESP32 devices with ESPHome connecting successfully to the same wifi network.

My use case is to scan for BLE messages from a Shelly Door/Window sensor, if that also factors further into the choice of firmware to install.

Any input much appreciated!

I can see that the device seems to have connected once to my LAN wifi during my attempts, but I keep getting an “Not connected to Authentication Failure” error displayed on the web UI when trying again.

I’m new to the Openmqtt gateway also, only used Tasmota up until now. I have the same board and had to flash again twice (esp32dev-ble) to be able to make it work. Have the feeling it was my fault, as the configuration screen seems to be a bit shaky and if you don’t get it right quickly it’s gone. That was my experience anyway.

So I got it working now. I think the thing was that I must’ve made a mistake with the wifi credentials and reflashing the board doesn’t fully erase that config, neither does the “erase wifi configuration” option in the UI. I flashed an ESPHome firmware onto the board, and then flashed OMG again, after doing that and configuring the wifi correctly on the first try on the fresh install it worked perfectly. I now get my Shelly BLU door/window sensor data straight into my MQTT broker without any pairing or extra shenanigans - superb!