WiFi Password for the AP is not accepted

I successfully flashed regular ESP32 DEV Board with esp32dev-ble code.
I also extracted MAC Address for the board I am using.
I can see and can connect to the OpenMQTTGateway_ESP32_BLE WiFi Access Point
from my Android phone.
But password (last 8 digits of MAC Address, all upper case) is not accepted.
So, what the problem is and how do I connect to the WiFi AP?

Hi @vitaliy_kh,

It doesn’t sound like you are

using a device sold by Theengs

or made you own build with

the macro -DWM_PWD_FROM_MAC=true

only then - according to the documentation - is the password

the last eight digits of the device MAC Address with upper case

otherwise it is, as stated at the beginning of the paragraph - “your_password” :wink:

Yrs, as I stated I am using regular ESP32 DEV Board from Amazon.
Does this mean I have to recompile everything myself instead of using pre-build downloads?
Why this password is required in a first place?
I am using many different ESP32 based project and always initial connection to the AP
for the WiFi configuration was not a password protected.
Just my opinion, this initial password protection is just an extra headache.

Since I will need to rebuild the project I have a question which one (if any) is more suitable
for my needs. I am looking for the MQTT-to-Bluetooth Gateway for controlling my adjustable
bed. It has a Bluetooth front end and it looks like it uses MQTT Commands for control.
My understanding is - Open MQTT Gateway projects are for collecting data from various
sensors and publishing data to the MQTT Broker. My needs are opposite. I need to control
my device (adjustable bed) by sending MQTT Commands.
Is this possible with Open MQTT Gateway?
And if “yes” which project to use for the plain ESP32 DEV Board?

No you don’t, just use and type in these characters:


and the pre-built binary esp32dev-ble you chose is the correct one for what you want to do.

Thank you very much. That was it. Somehow I was confused.
Now my device is on my WiFi network.
How do I access the configuration page now?
I was lazy to configure everything from my phone assuming I will be able to get to the config
from the PC. However I cannot connect browser to the DHCP assigned IP.

For me the captive portal comes up the same as on the phone when connecting to the initial AP network with your_password.

Have you made sure to disconenct fully from the AP with the phone?

Not sure why this would not come up on your PC, not knowing which OS you are using, but the IP to connect to manually with the browser is not the DHCP assigned one of your PC, but the router one, which in this case is the AP/ESP32.

Didn’t read properly that your device is already on your WiFi network, so you must have entered the WiFi credentials already with your phone. You’d have to reset/reflash the device to enter additional data, if you haven’t entered the MQTT details initially, as after the initial setup credetials can only be changed via MQTT commands, which obviously only works if MQQT works.

In the upcoming release this will be possible to adjust and change with the introduction of the Web UI.

Ok, did it.
Now I have a different problem.
Existing/current password for the Home Assistant MQTT Broker is too long and does not
fit into password field for the MQTT Broker.
I tried to reconfigure password for the HA Mosquitto MQTT Broker but this did not work.
It simply did not accept my new password unless i tried this in a wrong place.
So how do I solve this (completely unexpected) problem?

I figured out how to add users to the HA MQTT Broker.
I am all set.

Thank you for your help.

1 Like