Wt32-eth01 with RFM69


I am trying to install OMG on wt32-eth01 with RFM69. I can successfully install OMG without RFM69 support, but as soon as I add RFM69 gateway, boards boots and then immediately crashes. If I remove ‘-DZgatewayRFM69=“RFM69”’ from the ini file, OMG installs and works without any issues. The same behaviour occurs no matter if I connect the radio or not.

This is my _env.ini file:

platform = ${com.esp32_platform}
board = wt32-eth01
board_build.mcu = esp32
board_build.f_cpu = 240000000L
framework = arduino
monitor_speed = 115200
upload_protocol = esptool
board_build.partitions = min_spiffs.csv
lib_deps =
build_flags =

This is serial output when the board boots and crashes:

configsip: 0, SPIWP:0xee
mode:DIO, clock div:1
ho 0 tail 12 room 4
entry 0x400805f0
************* WELCOME TO OpenMQTTGateway **************
[ 130][E][Preferences.cpp:50] begin(): nvs_open failed: NOT_FOUND
N: SYS config not found
N: OpenMQTTGateway Version: v1.7.0
T: mounting FS…
T: mounted file system
T: reading config file
T: opened config file
“mqtt_server”: “”,
“mqtt_port”: “1883”,
“mqtt_user”: “user”,
“mqtt_pass”: “*",
“mqtt_topic”: “rfm69gw1/”,
“gateway_name”: “rfm69gw1”,
“mqtt_broker_secure”: false,
“mqtt_broker_cert”: “”,
“mqtt_ss_index”: 0,
“ota_server_cert”: “”,
“ota_pass”: "

T: parsed json, size: 388
N: Config loaded from flash
T: Spl eth cfg
T: Ethernet Started
N: Ethernet Connected
T: Connecting to Ethernet
T: .
T: OpenMQTTGateway MAC: A0:A3:B3:21:AC:47
T: OpenMQTTGateway IP:
T: OpenMQTTGateway link speed: 100 Mbps
T: .
T: OpenMQTTGateway mac: A0:A3:B3:21:AC:44
T: OpenMQTTGateway ip:
T: Port: 1883
T: Mqtt server:

When the board boots, I can ping it for one or two times and then it crashes. After it crashes I can’t even ping the board. If I disable RFM69, board works without any issues and I can ping it constantly. Also, when it boots without RFM69 it connects to MQTT and sends MQTT messages without any issues.

And ideas on how can I make this work?


Anyone has any idea how to troubleshoot this? To make sure my board and connections are good, I tried to upload the pre-made image (OpenMQTTGateway v1.7.0) and it works without any issues.

I also tried to install the gateway code from this repo: GitHub - strange-v/RadioSensors: A solar-powered node that stores energy in a supercapacitor, wakes-up regularly, measures different parameters and sends them to a gateway. since it uses similar setup and it also works, including the radio (at least radio init outputs OK message, haven’t tried with another radio node).

If anyone has any idea for troubleshooting, happy to try and make this work. I assume other people would find WT32-ETH01 with RFM69 a useful setup.